summaryrefslogtreecommitdiff
path: root/app-misc/c_rehash/c_rehash-1.0.2g_p8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/c_rehash/c_rehash-1.0.2g_p8.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/c_rehash/c_rehash-1.0.2g_p8.ebuild')
-rw-r--r--app-misc/c_rehash/c_rehash-1.0.2g_p8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/c_rehash/c_rehash-1.0.2g_p8.ebuild b/app-misc/c_rehash/c_rehash-1.0.2g_p8.ebuild
new file mode 100644
index 000000000000..b6f24de2b58c
--- /dev/null
+++ b/app-misc/c_rehash/c_rehash-1.0.2g_p8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+MY_P="openssl-${PV/_p/-}"
+
+DESCRIPTION="c_rehash script written in POSIX shell for OpenSSL"
+HOMEPAGE="https://www.openssl.org/ https://github.com/pld-linux/openssl/"
+SRC_URI="https://github.com/pld-linux/openssl/archive/auto/th/${MY_P}.tar.gz"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl:0 )
+"
+
+S="${WORKDIR}/openssl-auto-th-${MY_P}"
+
+src_prepare() {
+ SSL_CNF_DIR="/etc/ssl"
+ sed -i \
+ -e "/^DIR=/s:=.*:=${EPREFIX}${SSL_CNF_DIR}:" \
+ -e '1iOPENSSL=openssl' \
+ openssl-c_rehash.sh || die #416717
+}
+
+src_install() {
+ newbin openssl-c_rehash.sh c_rehash
+}