summaryrefslogtreecommitdiff
path: root/app-misc/asciinema
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /app-misc/asciinema
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'app-misc/asciinema')
-rw-r--r--app-misc/asciinema/Manifest2
-rw-r--r--app-misc/asciinema/asciinema-2.0.2.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/asciinema/Manifest b/app-misc/asciinema/Manifest
index f42673750293..f50dcfe22bd3 100644
--- a/app-misc/asciinema/Manifest
+++ b/app-misc/asciinema/Manifest
@@ -1,3 +1,5 @@
DIST asciinema-2.0.1.tar.gz 48597 BLAKE2B 9179d19c3c6980f35004145fc109dfa938fa020e1982389f7309c7716f8e18914fb8db46e74b2d778b043399d00a3348e499e9fc1849f5f02e1a729c8bde6084 SHA512 abc7e2a83032520d42b45524fbd103bd974b6857274fbb923b274d11f0a81a8d06cd1e97f1b7d6432a47e1ded6df5e37e52c69caaf7f15b1bf8b53f17dfc07d1
+DIST asciinema-2.0.2.tar.gz 50058 BLAKE2B db04e21f41b76a7b2be1ca119b2c0a2ff29c9e525c35180d2506722b12c7d139087d0a102bd984cecd7d69e2da0ce8ac0f4bc83c631bc1373fecc8de2d29f107 SHA512 27ae831494c2532270940c3e0fedc87ebbdc1e9d8d24c37d1b63d3f74d9722d38e867fa1b46656249e5b0a84ed7ed32bb21da65f06e9c6a8b787aebdce2068f3
EBUILD asciinema-2.0.1.ebuild 715 BLAKE2B 527c1dd6251ecf999f613409adc0da06eebdf08a12b01dff5030694e57fab13b03d385283bdd654d9522f8bdf566d4b2af54e9b95bbedb3df553e985c211cb41 SHA512 a7932f629ff6472e905931fd246702d1f308229962e93acabb48589426bf852423ab7ebe763d528581096434fa68f387d5262b918087e6aa1a525eb20ba3a085
+EBUILD asciinema-2.0.2.ebuild 712 BLAKE2B f3933813b9f7d0d25c13172bce141cc2a1b02b31319780a51b112574156ca386bba7c9c326258f495d024f4b354a688da36e04c226f63795b625c2c7004201fd SHA512 d7f62def4f26068bf8432295ff238accd1a7d70da1eed2d59925fd4971c72b4dec58f8d1543f3d516a3f73be2feed3c4b946ca88ffc4e5ec0a962462ebe28451
MISC metadata.xml 352 BLAKE2B a3fc1910fe080d3617e64abfa1d758ac162556451fbdf1500b5b7b5ae0ecc703004483f2e0a322bccabe2857319faf3ad011f75ddf676c950b5fe59a5feeda1e SHA512 382168389e0950d78c6df79b6ad6dcf8bdf54fc9f877b23dd1e69c3983e931590c82a26694279b83834121af33a4aa8915a9c1907da2bd617b895a2cb4c31d74
diff --git a/app-misc/asciinema/asciinema-2.0.2.ebuild b/app-misc/asciinema/asciinema-2.0.2.ebuild
new file mode 100644
index 000000000000..a44b1367cd19
--- /dev/null
+++ b/app-misc/asciinema/asciinema-2.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Command line recorder for asciinema.org service"
+HOMEPAGE="https://asciinema.org/ https://pypi.org/project/asciinema/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i -e "s|data_files=\[('share/doc/asciinema|&-${PVR}|" setup.py || die
+}
+
+python_test() {
+ nosetests || die
+}