summaryrefslogtreecommitdiff
path: root/app-misc/ansiweather/ansiweather-1.19.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-06 23:28:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-06 23:28:41 +0100
commit91f19a3f41e80c4ab434a07636edb90912ef7556 (patch)
tree94510a6b3336b3129759452bf1811330e591c0c0 /app-misc/ansiweather/ansiweather-1.19.0.ebuild
parent3d1ec36f5f52760f2431b79c71dd9b7aaefbc9ee (diff)
gentoo auto-resync : 06:04:2023 - 23:28:41
Diffstat (limited to 'app-misc/ansiweather/ansiweather-1.19.0.ebuild')
-rw-r--r--app-misc/ansiweather/ansiweather-1.19.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/ansiweather/ansiweather-1.19.0.ebuild b/app-misc/ansiweather/ansiweather-1.19.0.ebuild
new file mode 100644
index 000000000000..f1703a0b844b
--- /dev/null
+++ b/app-misc/ansiweather/ansiweather-1.19.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Weather in terminal, with ANSI colors and Unicode symbols"
+HOMEPAGE="https://github.com/fcambus/ansiweather/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fcambus/${PN}.git"
+else
+ SRC_URI="https://github.com/fcambus/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ app-misc/jq
+ sys-devel/bc
+ || ( net-misc/curl net-ftp/ftp net-misc/wget )
+"
+
+DOCS=( AUTHORS ChangeLog README.md ansiweatherrc.example )
+
+src_install() {
+ exeinto /usr/bin
+ doexe ${PN}
+
+ doman ${PN}.1
+
+ einstalldocs
+}