summaryrefslogtreecommitdiff
path: root/app-misc/anki/anki-2.1.15-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /app-misc/anki/anki-2.1.15-r1.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'app-misc/anki/anki-2.1.15-r1.ebuild')
-rw-r--r--app-misc/anki/anki-2.1.15-r1.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-misc/anki/anki-2.1.15-r1.ebuild b/app-misc/anki/anki-2.1.15-r1.ebuild
index f97f7bb0fbcb..b5fc94f7294f 100644
--- a/app-misc/anki/anki-2.1.15-r1.ebuild
+++ b/app-misc/anki/anki-2.1.15-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="sqlite"
inherit desktop optfeature python-single-r1 xdg
@@ -21,22 +21,22 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
- >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_MULTI_USEDEP}]
- >=dev-python/PyQtWebEngine-5.12[${PYTHON_MULTI_USEDEP}]
- >=dev-python/httplib2-0.7.4[${PYTHON_MULTI_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
- dev-python/decorator[${PYTHON_MULTI_USEDEP}]
- dev-python/jsonschema[${PYTHON_MULTI_USEDEP}]
- dev-python/markdown[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
- dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_USEDEP}]
+ >=dev-python/PyQtWebEngine-5.12[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
')
"
BDEPEND="test? (
${RDEPEND}
$(python_gen_cond_dep '
- dev-python/nose[${PYTHON_MULTI_USEDEP}]
- dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
')
)
"