summaryrefslogtreecommitdiff
path: root/app-misc/abook
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/abook
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/abook')
-rw-r--r--app-misc/abook/Manifest5
-rw-r--r--app-misc/abook/abook-0.6.1-r1.ebuild53
-rw-r--r--app-misc/abook/abook-0.6.1.ebuild46
-rw-r--r--app-misc/abook/files/abook-0.6.1-tinfo.patch18
-rw-r--r--app-misc/abook/metadata.xml12
5 files changed, 134 insertions, 0 deletions
diff --git a/app-misc/abook/Manifest b/app-misc/abook/Manifest
new file mode 100644
index 000000000000..65c9312255a9
--- /dev/null
+++ b/app-misc/abook/Manifest
@@ -0,0 +1,5 @@
+AUX abook-0.6.1-tinfo.patch 531 BLAKE2B 8acbb9fc21f2e78c508a1daa481d626501f12d22bf815b2663415d624a1a5e31e378cf6a741bd2a310898dbe6c18fa88137df238b760b0d5aebaa4f695cfc1a6 SHA512 1e0b7e3c2134e39b2fcece60a3c31927a6c4bd1049c9f14b1ed3426111efe035a433878dcd965bf1a3756daba75ebdf6983c0cd777bb4b1a92e62199a16f10a1
+DIST abook-0.6.1.tar.gz 319558 BLAKE2B 9d750d97aac2336f1de22121035c0fc9c4707d970976f95890907e5ae2ae3249f563dc45fb34c32c2a5303a9cdb35256dc4581b5759058e14486ca2a7cfe3cdf SHA512 993895ef2fd6d98d50db610699f8f0a28112778065ac56484373eb814afd8ab7371201fc21506c090514f4b29570ec229dc62c606ab068301152567e2c47fe66
+EBUILD abook-0.6.1-r1.ebuild 943 BLAKE2B ac67f194aaff7772d4457da67f5068514fd8801e6e891e427e569659c36d716b5fdf708361f4178f2ea6794808c17ab6789982e4a04946c1d440664d26d165f6 SHA512 50aaabde17ba2d54718fe219fbe8b87d7feb9db3a84d2195be7dd847302dbf68b408df5affcd6c1e264fcefd0f904b0db666f514500c3ae7d5b5fbf4bad0af78
+EBUILD abook-0.6.1.ebuild 961 BLAKE2B b9c6b2f4019cfaeef68af15c009553e5c874f9fa460059ea0a9bad6d0edeffdf5f5c2ef239542135848e9a958d5d9183f8696c43d67d0cdd5875bfab3f24115e SHA512 e79e18762afecda642e07011ab4cb2cdc9ff52903b28648b77a8fbf5abb86f0779fda94ab5a08b1e1c471956b42abf4a074bbfb006268ff1e282a1418ce0c907
+MISC metadata.xml 423 BLAKE2B 4ab53b2240a614737a3a9b3b377b1e342a7d61927947a7990919ca5ec03fb3c40c8bde39fb878abb27a00d7c94c65279e0892d4f121f045333fc8ae6b3af910d SHA512 1c7a4d398dcf82207508d4d05eac280df7561abe860a67b673b52ff9be46faabfed38a80c6224f712a8a8c73a04f9b68be33d3d128a5f58a5e9441e2f93abea8
diff --git a/app-misc/abook/abook-0.6.1-r1.ebuild b/app-misc/abook/abook-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..37e0289c6c32
--- /dev/null
+++ b/app-misc/abook/abook-0.6.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${P/_/}"
+DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client"
+HOMEPAGE="http://abook.sourceforge.net/"
+SRC_URI="http://abook.sourceforge.net/devel/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ sys-libs/ncurses
+ sys-libs/readline
+ dev-libs/libvformat
+ nls? ( virtual/libintl )"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( BUGS ChangeLog FAQ README TODO sample.abookrc )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.1-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-curses \
+ --with-readline \
+ --enable-vformat \
+ $(use_enable nls)
+}
+
+src_compile() {
+ # bug 570428
+ emake CFLAGS="${CFLAGS} -std=gnu89"
+}
+
+src_install() {
+ default
+}
diff --git a/app-misc/abook/abook-0.6.1.ebuild b/app-misc/abook/abook-0.6.1.ebuild
new file mode 100644
index 000000000000..63f75d43f870
--- /dev/null
+++ b/app-misc/abook/abook-0.6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools
+
+MY_P="${P/_/}"
+DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client"
+HOMEPAGE="http://abook.sourceforge.net/"
+SRC_URI="http://abook.sourceforge.net/devel/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+IUSE="nls"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline
+ dev-libs/libvformat
+ nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # TODO: do the right thing and find out whats wrong with Makefile.in
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-curses \
+ --with-readline \
+ --enable-vformat \
+ $(use_enable nls)
+}
+
+src_compile() {
+ # bug 570428
+ emake CFLAGS="${CFLAGS} -std=gnu89"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc BUGS ChangeLog FAQ README TODO sample.abookrc
+}
diff --git a/app-misc/abook/files/abook-0.6.1-tinfo.patch b/app-misc/abook/files/abook-0.6.1-tinfo.patch
new file mode 100644
index 000000000000..e8c4585dbcb4
--- /dev/null
+++ b/app-misc/abook/files/abook-0.6.1-tinfo.patch
@@ -0,0 +1,18 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -86,6 +86,7 @@
+
+ AC_CHECK_LIB(ncursesw, initscr,
+ [LIBS="$LIBS -lncursesw"
++ AC_SEARCH_LIBS(cbreak, tinfo)
+ if test x$abook_cv_curses = x/usr -a -d /usr/include/ncursesw; then
+ CPPFLAGS="$CPPFLAGS -I/usr/include/ncursesw"
+ fi
+@@ -93,6 +94,7 @@
+ ac_widec_possible=no
+ AC_CHECK_LIB(ncurses, initscr,
+ [LIBS="$LIBS -lncurses"
++ AC_SEARCH_LIBS(cbreak, tinfo)
+ if test x$abook_cv_curses = x/usr -a -d /usr/include/ncurses; then
+ CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"
+ fi
diff --git a/app-misc/abook/metadata.xml b/app-misc/abook/metadata.xml
new file mode 100644
index 000000000000..6a92d05f0ab5
--- /dev/null
+++ b/app-misc/abook/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>net-mail@gentoo.org</email>
+ <name>Net-Mail</name>
+ </maintainer>
+ <longdescription>abook is a text-based addressbook program for the mutt mail client.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">abook</remote-id>
+ </upstream>
+</pkgmetadata>