summaryrefslogtreecommitdiff
path: root/app-misc/abook/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /app-misc/abook/files
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'app-misc/abook/files')
-rw-r--r--app-misc/abook/files/abook-0.6.1-tinfo.patch18
-rw-r--r--app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch44
-rw-r--r--app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch31
-rw-r--r--app-misc/abook/files/abook-0.6.1-vformat.patch5
4 files changed, 77 insertions, 21 deletions
diff --git a/app-misc/abook/files/abook-0.6.1-tinfo.patch b/app-misc/abook/files/abook-0.6.1-tinfo.patch
deleted file mode 100644
index 3c12032932f1..000000000000
--- a/app-misc/abook/files/abook-0.6.1-tinfo.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -86,6 +86,7 @@
-
- AC_CHECK_LIB(ncursesw, initscr,
- [LIBS="$LIBS -lncursesw"
-+ AC_SEARCH_LIBS(cbreak, tinfow, LIBS="$LIBS -ltinfow")
- if test x$abook_cv_curses = x/usr -a -d /usr/include/ncursesw; then
- CPPFLAGS="$CPPFLAGS -I/usr/include/ncursesw"
- fi
-@@ -93,6 +94,7 @@
- ac_widec_possible=no
- AC_CHECK_LIB(ncurses, initscr,
- [LIBS="$LIBS -lncurses"
-+ AC_SEARCH_LIBS(cbreak, tinfo, LIBS="$LIBS -ltinfo")
- if test x$abook_cv_curses = x/usr -a -d /usr/include/ncurses; then
- CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"
- fi
diff --git a/app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch b/app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch
new file mode 100644
index 000000000000..e6f98906af3e
--- /dev/null
+++ b/app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch
@@ -0,0 +1,44 @@
+From: Sam James <sam@gentoo.org>
+Date: Wed, 21 Apr 2021 06:06:13 +0100
+Subject: Use PKG_CHECK_MODULES for ncurses
+
+We don't _always_ have split tinfo, e.g. Prefix.
+--- a/configure.ac
++++ b/configure.ac
+@@ -74,31 +74,9 @@ dnl -------------------
+ dnl (n)curses detection
+ dnl -------------------
+
+-abook_cv_curses=/usr
+-AC_ARG_WITH(curses, [ --with-curses=DIR Where ncurses is installed ],
+- [if test $withval != yes; then
+- abook_cv_curses=$withval
+- fi
+- if test x$abook_cv_curses != x/usr; then
+- LDFLAGS="-L${abook_cv_curses}/lib $LDFLAGS"
+- CPPFLAGS="$CPPFLAGS -I${abook_cv_curses}/include"
+- fi])
+-
+-AC_CHECK_LIB(ncursesw, initscr,
+- [LIBS="$LIBS -lncursesw"
+- if test x$abook_cv_curses = x/usr -a -d /usr/include/ncursesw; then
+- CPPFLAGS="$CPPFLAGS -I/usr/include/ncursesw"
+- fi
+- AC_CHECK_HEADERS(ncurses.h)],[
+- ac_widec_possible=no
+- AC_CHECK_LIB(ncurses, initscr,
+- [LIBS="$LIBS -lncurses"
+- if test x$abook_cv_curses = x/usr -a -d /usr/include/ncurses; then
+- CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"
+- fi
+- AC_CHECK_HEADERS(ncurses.h)],
+- [CF_CURSES_LIBS])
+- ])
++PKG_CHECK_MODULES(ncurses, ncurses)
++LDFLAGS="${ncurses_LIBS} $LDFLAGS"
++CPPFLAGS="${ncurses_CFLAGS} $CPPFLAGS"
+
+ dnl --------------------------
+ dnl end of (n)curses detection
+--
+
diff --git a/app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch b/app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch
new file mode 100644
index 000000000000..1a35e636964d
--- /dev/null
+++ b/app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch
@@ -0,0 +1,31 @@
+From: Sam James <sam@gentoo.org>
+Date: Wed, 21 Apr 2021 06:20:13 +0100
+Subject: Use more modern autoconf archive macro for readline
+
+The previous macro used was pretty obsolete and certainly didn't work
+on Gentoo Prefix on Darwin anyway.
+--- a/configure.ac
++++ b/configure.ac
+@@ -86,19 +86,9 @@ dnl ------------------
+ dnl readline detection
+ dnl ------------------
+
+-abook_cv_readline=/usr
+-AC_ARG_WITH(readline, [ --with-readline=DIR Where readline is installed ],
+- [if test $withval != yes; then
+- abook_cv_readline=$withval
+- fi
+- if test x$abook_cv_readline != x/usr; then
+- LDFLAGS="-L${abook_cv_readline}/lib $LDFLAGS"
+- CPPFLAGS="$CPPFLAGS -I${abook_cv_readline}/include"
+- fi])
+-
+-AC_LIB_READLINE
+-
+-if test x$ac_cv_lib_readline = xno -o x$ac_cv_lib_readline_history = xno; then
++AX_LIB_READLINE
++
++if test x$ax_cv_lib_readline = xno -o x$ax_cv_lib_readline_history = xno; then
+ AC_MSG_ERROR([*** readline library not found or it doesn't support history ***])
+ fi
+
diff --git a/app-misc/abook/files/abook-0.6.1-vformat.patch b/app-misc/abook/files/abook-0.6.1-vformat.patch
index 0808852e6b20..07a68a8ecb11 100644
--- a/app-misc/abook/files/abook-0.6.1-vformat.patch
+++ b/app-misc/abook/files/abook-0.6.1-vformat.patch
@@ -1,6 +1,5 @@
-diff -ru abook-0.6.1.orig/configure.ac abook-0.6.1/configure.ac
---- abook-0.6.1.orig/configure.ac 2020-05-24 19:10:09.826143646 +0200
-+++ abook-0.6.1/configure.ac 2020-05-24 19:10:52.088381318 +0200
+--- a/configure.ac
++++ b/configure.ac
@@ -140,6 +140,7 @@
if test x$vformat = xtrue; then
AC_CHECK_HEADER([vf_iface.h], [