summaryrefslogtreecommitdiff
path: root/app-metrics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-17 04:01:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-17 04:01:14 +0100
commitcb627578a344c874750e23e7eb59b1acc85aa639 (patch)
treee89fc6cd15c4b9a2af97553564bcd9d2a8a758a5 /app-metrics
parentaccc284898c2b08d44aca3a4207c0e1c9fac05f5 (diff)
gentoo auto-resync : 17:10:2023 - 04:01:13
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/Manifest.gzbin6785 -> 6950 bytes
-rw-r--r--app-metrics/smartctl_exporter/Manifest4
-rw-r--r--app-metrics/smartctl_exporter/metadata.xml10
-rw-r--r--app-metrics/smartctl_exporter/smartctl_exporter-0.11.0.ebuild51
4 files changed, 65 insertions, 0 deletions
diff --git a/app-metrics/Manifest.gz b/app-metrics/Manifest.gz
index 9cea1b605f45..3171e23ec4a0 100644
--- a/app-metrics/Manifest.gz
+++ b/app-metrics/Manifest.gz
Binary files differ
diff --git a/app-metrics/smartctl_exporter/Manifest b/app-metrics/smartctl_exporter/Manifest
new file mode 100644
index 000000000000..d05eaa181a7d
--- /dev/null
+++ b/app-metrics/smartctl_exporter/Manifest
@@ -0,0 +1,4 @@
+DIST smartctl_exporter-0.11.0-vendor.tar.xz 1348836 BLAKE2B 06999c2df7891d6579a227dc5eab44240f923f3466ce1da8443bc40afcb7d9c493f94d50a083ea26e03969b89c9cff4e977f9cffc8529dac5c323212c139dd9e SHA512 c54bf342e56db7086a3844d96f910a18b9d0e19a434b554421e9c70b02fdf3b2307da6662a0e02de93adedf9484444bbbcb7225659b26273e6106cbf73aa3dbd
+DIST smartctl_exporter-0.11.0.tar.gz 29097 BLAKE2B 7e3d85588a83380f8d579a918677d9910ba1922212af65b1918a379315e9f2321f617c5d884fd72086019ddac353817da5d1ec71a8a8b0ecb3edb24f66dd75fa SHA512 2c86d051d17c55e3122130ad4733c5911310698a89d8782a61f3b5541cb7aa689994338125eaa5ee41fdcddbdd8316a6736c734ff5dee6fe0d6c0a2b131fff66
+EBUILD smartctl_exporter-0.11.0.ebuild 1360 BLAKE2B 98816436662949c516605a96d24038218969d3e55d9fe99c50846d2c7aa9147220a2308b2e069cc87b8bb233f2549020a5dbfce2991ac55b3cf190e8bb4519a0 SHA512 27173c3e973874d31a0c4486cfc78f15202668fe9f21b0fc11677ada1934e675ae2ff16a3670755996195dc195a066e1d9361cc51be77dfaeaeb87cb8916550e
+MISC metadata.xml 322 BLAKE2B 067be01a985da3e1d0126a95004d71e9638901bb5f0c2d7ab0c49896434fc2190ae2723bc1c463592a08cec887bca884138e79de847b475d8c7f847f2a22518d SHA512 faaab61fcb4237332a853c8851dd46569e90b9845f8761f9e003d826faab13b76dff55a6a66868ec53ab1b5247b94bf74e86f725a6f16a2652c1408359debdf1
diff --git a/app-metrics/smartctl_exporter/metadata.xml b/app-metrics/smartctl_exporter/metadata.xml
new file mode 100644
index 000000000000..ec7f20a9016f
--- /dev/null
+++ b/app-metrics/smartctl_exporter/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">prometheus-community/smartctl_exporter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-metrics/smartctl_exporter/smartctl_exporter-0.11.0.ebuild b/app-metrics/smartctl_exporter/smartctl_exporter-0.11.0.ebuild
new file mode 100644
index 000000000000..93fd041d43a9
--- /dev/null
+++ b/app-metrics/smartctl_exporter/smartctl_exporter-0.11.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Export smartctl statistics to prometheus"
+HOMEPAGE="https://github.com/prometheus-community/smartctl_exporter"
+# Upstream LICENSE file is wrong see https://github.com/prometheus-community/smartctl_exporter/pull/113
+LICENSE="Apache-2.0"
+SLOT="0"
+BDEPEND="dev-util/promu"
+DEPEND="dev-lang/go"
+RDEPEND="sys-apps/smartmontools"
+KEYWORDS="~amd64 ~x86"
+
+# uncomment the first setting of MY_PV for a normal release
+# MY_PV="v${PV/_rc/-rc.}"
+# set MY_PV to the full commit hash for a snapshot release
+MY_PV_HASH=
+: ${MY_PV_HASH_FOR_VENDOR:=${MY_PV_HASH}}
+if [[ -n "${MY_PV_HASH}" ]]; then
+ MY_PV=${MY_PV_HASH}
+ SMARTCTL_EXPORTER_COMMIT=${MY_PV_HASH:0:8}
+ SRC_URI_UPSTREAM="${HOMEPAGE}/archive/${MY_PV}.tar.gz"
+else
+ MY_PV=$PV
+ SMARTCTL_EXPORTER_COMMIT=
+ SRC_URI_UPSTREAM="${HOMEPAGE}/archive/refs/tags/v${PV}.tar.gz"
+fi
+MY_P=${PN}-${MY_PV}
+SRC_URI_VENDOR="https://dev.gentoo.org/~robbat2/distfiles/${MY_P}-vendor.tar.xz"
+SRC_URI="
+ ${SRC_URI_UPSTREAM} -> ${P}.tar.gz
+ ${SRC_URI_VENDOR}
+ "
+
+src_prepare() {
+ default
+ if [[ -n $SMARTCTL_EXPORTER_COMMIT ]]; then
+ sed -i -e "s/{{.Revision}}/${SMARTCTL_EXPORTER_COMMIT}/" .promu.yml || die
+ fi
+}
+
+src_compile() {
+ emake build PROMU='/usr/bin/promu'
+}
+
+src_install() {
+ dodoc *.md
+ dobin ${PN}
+}