summaryrefslogtreecommitdiff
path: root/app-metrics/prom2json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
commit8c364c784966be1700ea39ae45028f3e9be9cae0 (patch)
treec1971211069b79e3831b71accd52a67a9fdc77a3 /app-metrics/prom2json
parent6bd95d1f6320b8666a31ec949183aaa3088aa16f (diff)
gentoo resync : 27.03.2018
Diffstat (limited to 'app-metrics/prom2json')
-rw-r--r--app-metrics/prom2json/Manifest3
-rw-r--r--app-metrics/prom2json/metadata.xml11
-rw-r--r--app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/app-metrics/prom2json/Manifest b/app-metrics/prom2json/Manifest
new file mode 100644
index 000000000000..4ea08c2b5ec4
--- /dev/null
+++ b/app-metrics/prom2json/Manifest
@@ -0,0 +1,3 @@
+DIST prom2json-0.1.0_p20170523.tar.gz 129179 BLAKE2B ef0e42e340d53894c31bff7018b668d8575fc3568584a43dc308955665ac6f59dbabf2d4605bc2a66957df57a29ebb7b3a4eef1f99537eefc2805a5ffd86904f SHA512 824f4c43f4a167dc7dde2f11e84cf482e5cdfa26ab11caf08a5461d525543c3491180f54694c4ae61fdd5dc9763ff16f6e29b332a64dc3ac52fdb7b9c0902571
+EBUILD prom2json-0.1.0_p20170523.ebuild 921 BLAKE2B 8c4c359398fd7941f127c2fec6f8a0306f53dee43d2948873ffffe840b27f35ce2753c787f2bdfc6445ef9371fa10b4edc36dc3c2565e358ee7f9c8fe868b6ad SHA512 85ba4728a68ea42bc69f196e0e027f38ece006b9af5b2c9fe2da30b2605f79dc568017132e2eaa116b109bc7f18109581c8d69df641f82c7ce0066ea5dd9d3f2
+MISC metadata.xml 330 BLAKE2B 0e691de7e25e1287ed59fe2606e788b073ca53a20e893ca26ae274968f42050cc6c86e8b62dbdfdd361d98f212386249cb0d028de54f52f6cc3e1b211e2da679 SHA512 17cb63ee862d80eb3e6d15cd209acee351873802eae2f3a943b17b68e8d042706c2eb6e4ee9b5bdc6e0c9901888eadf6fbd3ee9969a517f417b25237b70b5470
diff --git a/app-metrics/prom2json/metadata.xml b/app-metrics/prom2json/metadata.xml
new file mode 100644
index 000000000000..eaf3cc3d6f87
--- /dev/null
+++ b/app-metrics/prom2json/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">prometheus/prom2json</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild b/app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild
new file mode 100644
index 000000000000..8bc84e323834
--- /dev/null
+++ b/app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/${PN}"
+EGIT_COMMIT="4a7436442837da72f9e211d99f0145dff3246b66"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A tool to scrape a Prometheus client and dump the result as JSON"
+HOMEPAGE="https://github.com/prometheus/prom2json"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${EGIT_COMMIT:0:7}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ mkdir -p bin || die
+ GOPATH="${S}" promu build -v --prefix ${PN} || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin ${PN}/${PN}
+ dodoc {README,CONTRIBUTING}.md
+ popd || die
+}