summaryrefslogtreecommitdiff
path: root/app-metrics/fritzbox_smarthome_exporter/fritzbox_smarthome_exporter-0.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-metrics/fritzbox_smarthome_exporter/fritzbox_smarthome_exporter-0.0.8.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-metrics/fritzbox_smarthome_exporter/fritzbox_smarthome_exporter-0.0.8.ebuild')
-rw-r--r--app-metrics/fritzbox_smarthome_exporter/fritzbox_smarthome_exporter-0.0.8.ebuild182
1 files changed, 182 insertions, 0 deletions
diff --git a/app-metrics/fritzbox_smarthome_exporter/fritzbox_smarthome_exporter-0.0.8.ebuild b/app-metrics/fritzbox_smarthome_exporter/fritzbox_smarthome_exporter-0.0.8.ebuild
new file mode 100644
index 000000000000..30019e7465c5
--- /dev/null
+++ b/app-metrics/fritzbox_smarthome_exporter/fritzbox_smarthome_exporter-0.0.8.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="Prometheus exporter for FRITZ!Box Smart Home"
+
+EGO_SUM=(
+ "github.com/alecthomas/template v0.0.0-20160405071501-a0175ee3bccc/go.mod"
+ "github.com/alecthomas/template v0.0.0-20190718012654-fb15b899a751/go.mod"
+ "github.com/alecthomas/units v0.0.0-20151022065526-2efee857e7cf/go.mod"
+ "github.com/alecthomas/units v0.0.0-20190717042225-c3de453c63f4/go.mod"
+ "github.com/beorn7/perks v0.0.0-20180321164747-3a771d992973"
+ "github.com/beorn7/perks v0.0.0-20180321164747-3a771d992973/go.mod"
+ "github.com/beorn7/perks v1.0.0/go.mod"
+ "github.com/beorn7/perks v1.0.1"
+ "github.com/beorn7/perks v1.0.1/go.mod"
+ "github.com/bpicode/fritzctl v1.4.23"
+ "github.com/bpicode/fritzctl v1.4.23/go.mod"
+ "github.com/cespare/xxhash/v2 v2.1.1"
+ "github.com/cespare/xxhash/v2 v2.1.1/go.mod"
+ "github.com/davecgh/go-spew v1.1.0"
+ "github.com/davecgh/go-spew v1.1.0/go.mod"
+ "github.com/davecgh/go-spew v1.1.1"
+ "github.com/davecgh/go-spew v1.1.1/go.mod"
+ "github.com/fatih/color v1.7.0"
+ "github.com/fatih/color v1.7.0/go.mod"
+ "github.com/go-kit/kit v0.8.0/go.mod"
+ "github.com/go-kit/kit v0.9.0/go.mod"
+ "github.com/go-logfmt/logfmt v0.3.0/go.mod"
+ "github.com/go-logfmt/logfmt v0.4.0/go.mod"
+ "github.com/go-stack/stack v1.8.0/go.mod"
+ "github.com/gogo/protobuf v1.1.1/go.mod"
+ "github.com/golang/protobuf v1.2.0/go.mod"
+ "github.com/golang/protobuf v1.3.1/go.mod"
+ "github.com/golang/protobuf v1.3.2/go.mod"
+ "github.com/golang/protobuf v1.4.0-rc.1/go.mod"
+ "github.com/golang/protobuf v1.4.0-rc.1.0.20200221234624-67d41d38c208/go.mod"
+ "github.com/golang/protobuf v1.4.0-rc.2/go.mod"
+ "github.com/golang/protobuf v1.4.0-rc.4.0.20200313231945-b860323f09d0/go.mod"
+ "github.com/golang/protobuf v1.4.0"
+ "github.com/golang/protobuf v1.4.0/go.mod"
+ "github.com/google/go-cmp v0.3.0/go.mod"
+ "github.com/google/go-cmp v0.3.1/go.mod"
+ "github.com/google/go-cmp v0.4.0"
+ "github.com/google/go-cmp v0.4.0/go.mod"
+ "github.com/google/gofuzz v1.0.0/go.mod"
+ "github.com/json-iterator/go v1.1.6/go.mod"
+ "github.com/json-iterator/go v1.1.9/go.mod"
+ "github.com/julienschmidt/httprouter v1.2.0"
+ "github.com/julienschmidt/httprouter v1.2.0/go.mod"
+ "github.com/konsorten/go-windows-terminal-sequences v1.0.1/go.mod"
+ "github.com/kr/logfmt v0.0.0-20140226030751-b84e30acd515/go.mod"
+ "github.com/kr/pretty v0.1.0"
+ "github.com/kr/pretty v0.1.0/go.mod"
+ "github.com/kr/pty v1.1.1/go.mod"
+ "github.com/kr/text v0.1.0"
+ "github.com/kr/text v0.1.0/go.mod"
+ "github.com/mattn/go-colorable v0.0.9"
+ "github.com/mattn/go-colorable v0.0.9/go.mod"
+ "github.com/mattn/go-isatty v0.0.3"
+ "github.com/mattn/go-isatty v0.0.3/go.mod"
+ "github.com/matttproud/golang_protobuf_extensions v1.0.1"
+ "github.com/matttproud/golang_protobuf_extensions v1.0.1/go.mod"
+ "github.com/modern-go/concurrent v0.0.0-20180228061459-e0a39a4cb421/go.mod"
+ "github.com/modern-go/concurrent v0.0.0-20180306012644-bacd9c7ef1dd/go.mod"
+ "github.com/modern-go/reflect2 v0.0.0-20180701023420-4b7aa43c6742/go.mod"
+ "github.com/modern-go/reflect2 v1.0.1/go.mod"
+ "github.com/mwitkow/go-conntrack v0.0.0-20161129095857-cc309e4a2223/go.mod"
+ "github.com/namsral/flag v1.7.4-pre"
+ "github.com/namsral/flag v1.7.4-pre/go.mod"
+ "github.com/pkg/errors v0.8.0/go.mod"
+ "github.com/pkg/errors v0.8.1/go.mod"
+ "github.com/pmezard/go-difflib v1.0.0"
+ "github.com/pmezard/go-difflib v1.0.0/go.mod"
+ "github.com/prometheus/client_golang v0.9.1/go.mod"
+ "github.com/prometheus/client_golang v1.0.0/go.mod"
+ "github.com/prometheus/client_golang v1.6.0"
+ "github.com/prometheus/client_golang v1.6.0/go.mod"
+ "github.com/prometheus/client_model v0.0.0-20180712105110-5c3871d89910"
+ "github.com/prometheus/client_model v0.0.0-20180712105110-5c3871d89910/go.mod"
+ "github.com/prometheus/client_model v0.0.0-20190129233127-fd36f4220a90/go.mod"
+ "github.com/prometheus/client_model v0.2.0"
+ "github.com/prometheus/client_model v0.2.0/go.mod"
+ "github.com/prometheus/common v0.4.1/go.mod"
+ "github.com/prometheus/common v0.9.1"
+ "github.com/prometheus/common v0.9.1/go.mod"
+ "github.com/prometheus/procfs v0.0.0-20181005140218-185b4288413d/go.mod"
+ "github.com/prometheus/procfs v0.0.2/go.mod"
+ "github.com/prometheus/procfs v0.0.11"
+ "github.com/prometheus/procfs v0.0.11/go.mod"
+ "github.com/sirupsen/logrus v1.2.0/go.mod"
+ "github.com/sirupsen/logrus v1.4.2/go.mod"
+ "github.com/stretchr/objx v0.1.0/go.mod"
+ "github.com/stretchr/objx v0.1.1/go.mod"
+ "github.com/stretchr/testify v1.2.2/go.mod"
+ "github.com/stretchr/testify v1.3.0"
+ "github.com/stretchr/testify v1.3.0/go.mod"
+ "github.com/stretchr/testify v1.4.0"
+ "github.com/stretchr/testify v1.4.0/go.mod"
+ "golang.org/x/crypto v0.0.0-20180904163835-0709b304e793/go.mod"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
+ "golang.org/x/net v0.0.0-20181114220301-adae6a3d119a/go.mod"
+ "golang.org/x/net v0.0.0-20190613194153-d28f0bde5980/go.mod"
+ "golang.org/x/sync v0.0.0-20181108010431-42b317875d0f/go.mod"
+ "golang.org/x/sync v0.0.0-20181221193216-37e7f081c4d4"
+ "golang.org/x/sync v0.0.0-20181221193216-37e7f081c4d4/go.mod"
+ "golang.org/x/sync v0.0.0-20190911185100-cd5d95a43a6e/go.mod"
+ "golang.org/x/sys v0.0.0-20180905080454-ebe1bf3edb33/go.mod"
+ "golang.org/x/sys v0.0.0-20181116152217-5ac8a444bdc5/go.mod"
+ "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
+ "golang.org/x/sys v0.0.0-20190422165155-953cdadca894/go.mod"
+ "golang.org/x/sys v0.0.0-20200106162015-b016eb3dc98e/go.mod"
+ "golang.org/x/sys v0.0.0-20200420163511-1957bb5e6d1f"
+ "golang.org/x/sys v0.0.0-20200420163511-1957bb5e6d1f/go.mod"
+ "golang.org/x/text v0.3.0/go.mod"
+ "golang.org/x/xerrors v0.0.0-20191204190536-9bdfabe68543"
+ "golang.org/x/xerrors v0.0.0-20191204190536-9bdfabe68543/go.mod"
+ "google.golang.org/protobuf v0.0.0-20200109180630-ec00e32a8dfd/go.mod"
+ "google.golang.org/protobuf v0.0.0-20200221191635-4d8936d0db64/go.mod"
+ "google.golang.org/protobuf v0.0.0-20200228230310-ab0ca4ff8a60/go.mod"
+ "google.golang.org/protobuf v1.20.1-0.20200309200217-e05f789c0967/go.mod"
+ "google.golang.org/protobuf v1.21.0"
+ "google.golang.org/protobuf v1.21.0/go.mod"
+ "gopkg.in/alecthomas/kingpin.v2 v2.2.6/go.mod"
+ "gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405"
+ "gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405/go.mod"
+ "gopkg.in/check.v1 v1.0.0-20190902080502-41f04d3bba15"
+ "gopkg.in/check.v1 v1.0.0-20190902080502-41f04d3bba15/go.mod"
+ "gopkg.in/yaml.v2 v2.2.1"
+ "gopkg.in/yaml.v2 v2.2.1/go.mod"
+ "gopkg.in/yaml.v2 v2.2.2/go.mod"
+ "gopkg.in/yaml.v2 v2.2.4/go.mod"
+ "gopkg.in/yaml.v2 v2.2.5"
+ "gopkg.in/yaml.v2 v2.2.5/go.mod"
+)
+go-module_set_globals
+
+HOMEPAGE="https://github.com/jayme-github/fritzbox_smarthome_exporter"
+SRC_URI="https://github.com/jayme-github/fritzbox_smarthome_exporter/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
+
+LICENSE="Apache-2.0 BSD GPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-util/promu"
+
+DEPEND="acct-group/fritzbox_smarthome_exporter
+ acct-user/fritzbox_smarthome_exporter"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ go build -v -o bin/${PN} || die
+}
+
+src_test() {
+ go test -v ./... || die
+}
+
+src_install() {
+ dobin bin/*
+ einstalldocs
+
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ # restrict access because conf.d entry could contain
+ # FRITZ!Box credentials
+ fperms 0640 /etc/conf.d/${PN}
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+}