summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-monocle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /app-leechcraft/lc-monocle
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'app-leechcraft/lc-monocle')
-rw-r--r--app-leechcraft/lc-monocle/Manifest2
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-9999.ebuild39
2 files changed, 26 insertions, 15 deletions
diff --git a/app-leechcraft/lc-monocle/Manifest b/app-leechcraft/lc-monocle/Manifest
index 17439871c9d7..ef7b340fe90b 100644
--- a/app-leechcraft/lc-monocle/Manifest
+++ b/app-leechcraft/lc-monocle/Manifest
@@ -1,2 +1,2 @@
-EBUILD lc-monocle-9999.ebuild 1013 BLAKE2B c7b16c6d9b044342c6f60e712642bfb8f072e14809c8689e9708e59cc0825a9c4bf4f6603a0ff94e06e16841d5c55295982c75ac35e94bc55f27f04a53c6ca7f SHA512 18e1c3aba49d625e8cf397270aee623653345ed2192d01f28ee004b026a541a5b637926f0ec81d22e075ded16800253ef0fd0ab251b60e79b828c2362e1d121f
+EBUILD lc-monocle-9999.ebuild 1093 BLAKE2B 09adf09769a43e0dacf7619f39910747a9f1162ada52af972d4b710194673eeb437a6e74a1220caa407cdf11e946d53047b8993c3a1fbf5b2b89ee4a623b4508 SHA512 16cad82423f32d6f86d929a0c11ca053e3d708cf164c2c8dbe4d98cca8b06848558aba9b5c8496b2750d3f0065c21c986edcc625a902c49dec78db834ebfcb54
MISC metadata.xml 501 BLAKE2B 011d2a76ddb262226145c480a00834e6818887722f0d2125275738e0203e693b56eedb6ae04622c6ea7590057b091a34747ca25f5598ef303bdfe06fb4f99363 SHA512 7cc94be02505c74347bc6a08624b666269928e3277e808aeae0ca6931afe715ae55d80dad48862b0a4ca52c49902f452594b3fa7ac0252ad45fd14575e9a5869
diff --git a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
index fcd13b3dd384..4b5bf380ecea 100644
--- a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
+++ b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit leechcraft
+inherit xdg-utils leechcraft
DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
@@ -13,20 +13,23 @@ IUSE="debug +djvu doc +fb2 +mobi +pdf +postscript"
REQUIRED_USE="postscript? ( pdf )"
-CDEPEND="~app-leechcraft/lc-core-${PV}
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
+DEPEND="~app-leechcraft/lc-core-${PV}
dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
dev-qt/qtxml:5
- pdf? ( app-text/poppler[qt5] )
- djvu? ( app-text/djvu )"
+ djvu? ( app-text/djvu )
+ pdf? ( app-text/poppler:= )
+"
-RDEPEND="${CDEPEND}
- postscript? ( app-text/ghostscript-gpl )"
+RDEPEND="${DEPEND}
+ postscript? ( app-text/ghostscript-gpl )
+"
-DEPEND="${CDEPEND}
- doc? ( app-doc/doxygen[dot] )"
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+"
src_configure() {
local mycmakeargs=(
@@ -37,10 +40,18 @@ src_configure() {
-DENABLE_MONOCLE_PDF=$(usex pdf)
-DENABLE_MONOCLE_POSTRUS=$(usex postscript)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r "${CMAKE_BUILD_DIR}"/out/html/*
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}