summaryrefslogtreecommitdiff
path: root/app-laptop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /app-laptop
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/Manifest.gzbin3257 -> 3256 bytes
-rwxr-xr-x[-rw-r--r--]app-laptop/pommed/files/pommed.rc0
-rwxr-xr-x[-rw-r--r--]app-laptop/tp_smapi/files/tp_smapi-0.40-initd0
-rw-r--r--app-laptop/tuxedo-control-center-bin/Manifest2
-rw-r--r--app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.0.ebuild78
-rw-r--r--app-laptop/tuxedo-keyboard/Manifest4
-rw-r--r--app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.0.8.ebuild (renamed from app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.0.3.ebuild)0
7 files changed, 82 insertions, 2 deletions
diff --git a/app-laptop/Manifest.gz b/app-laptop/Manifest.gz
index ba427d925a2f..2149c3ebb67a 100644
--- a/app-laptop/Manifest.gz
+++ b/app-laptop/Manifest.gz
Binary files differ
diff --git a/app-laptop/pommed/files/pommed.rc b/app-laptop/pommed/files/pommed.rc
index 23904fc7d3a0..23904fc7d3a0 100644..100755
--- a/app-laptop/pommed/files/pommed.rc
+++ b/app-laptop/pommed/files/pommed.rc
diff --git a/app-laptop/tp_smapi/files/tp_smapi-0.40-initd b/app-laptop/tp_smapi/files/tp_smapi-0.40-initd
index 3b8c10d9274a..3b8c10d9274a 100644..100755
--- a/app-laptop/tp_smapi/files/tp_smapi-0.40-initd
+++ b/app-laptop/tp_smapi/files/tp_smapi-0.40-initd
diff --git a/app-laptop/tuxedo-control-center-bin/Manifest b/app-laptop/tuxedo-control-center-bin/Manifest
index 6257c99a6cca..b60599f6f9c6 100644
--- a/app-laptop/tuxedo-control-center-bin/Manifest
+++ b/app-laptop/tuxedo-control-center-bin/Manifest
@@ -1,3 +1,5 @@
DIST tuxedo-control-center_1.0.4.rpm 71316848 BLAKE2B 9368825985f292556d0c4b60000ff05d8363b300be34708c4fb2f7ac284218b48051deaa30d62707aefa28db4b54c02a2f82d12db33bf56341f257a47bde13f2 SHA512 6881069a99b97b03234fca93423c72a9a8c2eca6d619d9cfd1712055d89d174ccc79a4931941cb8d65a28c10413e0faad2a9f16ad444d29799a1cfe14b9879d8
+DIST tuxedo-control-center_1.1.0.rpm 71893232 BLAKE2B f41702ba7faae2375e95a0bfe838dace738eb9f34364bac78bba405ca791c0b055ff7c7a05572172b04ec1acd87dad7e3abc29df06bba84296a8bc4c76d5d9c5 SHA512 3b98f27ada98ff77d0fc84425042dc63431fcd169ba28f5a0585589846e8dca1405a9d258bdf90f86d0e363a827bafa80e58c8dd56e94042e3b0f0d726737e05
EBUILD tuxedo-control-center-bin-1.0.4.ebuild 1961 BLAKE2B 60bba00e9a047286ad392880d84535e621f26e79cabb3dd862425c45b1ff16fea3f408e81fccc38a5109ea7678208b292933c99d78124fd8c9bb12a7272b468b SHA512 d0ac29268c65bb130066968da12a4ffdba2360cd49b8b8d7fa95cd475d3769c3f03df88f9953d996ad3d13716fd609b5164555f8872834685e2cab0eb82f629c
+EBUILD tuxedo-control-center-bin-1.1.0.ebuild 1961 BLAKE2B 2421880abff5b2717d289203473d7c87d9d2ddcd85cc55f828824afc787a98780b7a55f2d8117edd032cc50839de366ac75f899ad39e0811c6532a94826a6e0d SHA512 89b0dbe213d0b99b82a037d02fbd8d560c676ac446da819ee5df94ccca286e99fcda29c3dff4bd0fb77a838d64817ba896141bb33ab9e87090997a5020f4731e
MISC metadata.xml 251 BLAKE2B c4b2c58fbe476fa27226d01a46b74c9506d938c1e14fe68ccbee1383f683d357ff87a3c1aacee177b7f3908333cd58540e446bc73ed8258359481c4b507c155e SHA512 f113d652bc4a2cded17c6fc788d425f8a5d1fac17709b4f0583c7d530cbba5093c4309d2539d169f733d8e8bff3c0e71e24ffe4ba6a81ebd5bab23191c0e4278
diff --git a/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.0.ebuild b/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.0.ebuild
new file mode 100644
index 000000000000..26e89d4b651e
--- /dev/null
+++ b/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm systemd xdg-utils
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="Tool to control performance, energy, fan and comfort settings on TUXEDO laptops"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-control-center"
+SRC_URI="https://rpm.tuxedocomputers.com/opensuse/15.2/x86_64/${MY_PN}_${PV}.rpm"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+RESTRICT="strip splitdebug"
+
+DEPEND="sys-power/tuxedo-cc-wmi"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+ rm -rf usr/lib
+ mkdir files
+}
+
+src_install() {
+ insinto /
+ doins -r usr opt
+ find . -type f -perm -a=x | while read f; do
+ chmod 0755 "${D}/${f}"
+ done
+
+ dosym ../../opt/tuxedo-control-center/tuxedo-control-center /usr/bin/tuxedo-control-center
+
+ insinto /usr/share/dbus-1/system.d/
+ doins opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/com.tuxedocomputers.tccd.conf
+
+ insinto /usr/share/polkit-1/actions
+ doins opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/de.tuxedocomputers.tcc.policy
+
+ systemd_dounit opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/tccd.service
+ systemd_dounit opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/tccd-sleep.service
+}
+
+pkg_config() {
+ ebegin "Reloading systemd"
+ systemctl daemon-reload
+ eend $?
+ ebegin "Enabling and starting tccd.service"
+ systemctl enable --now tccd
+ eend $?
+ ebegin "Enabling and starting tccd-sleep.service"
+ systemctl enable --now tccd-sleep
+ eend $?
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ elog
+ elog "You need to enable tccd and tccd-sleep service before running tuxedo-control-center"
+ elog
+ elog "For your convenience you may just call:"
+ elog " emerge --config =${P}"
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/app-laptop/tuxedo-keyboard/Manifest b/app-laptop/tuxedo-keyboard/Manifest
index c60b7c9ce56e..5e32a6562c09 100644
--- a/app-laptop/tuxedo-keyboard/Manifest
+++ b/app-laptop/tuxedo-keyboard/Manifest
@@ -1,5 +1,5 @@
DIST tuxedo-keyboard-2.0.5.tar.gz 31001 BLAKE2B 931d011e2ac521cef1670a8952886c1ac9b2476c6227c2b3cfce28d52622d3869f3c55773279eea3cbcc94d7c5b12d5d5653a8e2f9c142d0c044fa23fddd958c SHA512 3b7a9331d04e2918f3452f9561b05f39ea458960c2ade299a368899638987178cfd33fa066a0835f88b14c240d7937692d7994ccf978749ea7fdc428e587e06a
-DIST tuxedo-keyboard-3.0.3.tar.gz 48275 BLAKE2B be4fd4a52cd578ec7db2d0f94c64ba842c2b28ecabbca10331024e104cf4dbaa655e0686f412141ac3ad6bc0430398797f628139a396e5a41ac73c33943230cf SHA512 6ebbde6ea9351f9fd7167d38d8b5f836d1fda2fbbcf80755e86c2b76c49cf263ad2e9cfc47bea3449387626d88d8c1725335c2861ec2ff5a76e64ef87e27d9fb
+DIST tuxedo-keyboard-3.0.8.tar.gz 50046 BLAKE2B 0457127a1f64a4d39a97b66cc50846aed86ba1249163e0958cc4da69476b367070815f859bfd1df2391e6480093e51ea29e26bd05ade9763d85d53bab4f6011a SHA512 f564980b8a353f9b6d6121f3b9d4408e7ab1b26d5587cedbe85acac8a93779af1be1b224927fa0f2a25ee50e6b1c6dd8401949fd54a6e89c1304ae057c777e7c
EBUILD tuxedo-keyboard-2.0.5-r1.ebuild 583 BLAKE2B 3633ae11af2f13a533feb53f2a3368ddc2b1a6a536903ecfe4312850d64b00f7f2ae1d81e12358515035e4bebbfe02640954602e7ae2898a7203f02d4f64c31d SHA512 eb48c301ebded725bb576736e611d8a187a0f9c9778cb272f6f1c881b108ea7b306e650f8822f78f9f5597b88344a55d80a6d9897b0cc305e54d558e5cf9914e
-EBUILD tuxedo-keyboard-3.0.3.ebuild 675 BLAKE2B 6aa6f7b4d2f6803f59fb21a927061d20473906accc20c58fcd752bb69261eb0ba91f14b46c7a4bc7e4dc0421e20620f8681b521e590d0ccdac4ff2eee2c59db8 SHA512 dadf0006d0c2740030fafc6379be6faafffef9ca845412cd3d99a36d4142c7565f9c4f6096ea6cf8731dda80c6b98ab3ff164cce891a481f1bb1ebc73ed1c28e
+EBUILD tuxedo-keyboard-3.0.8.ebuild 675 BLAKE2B 6aa6f7b4d2f6803f59fb21a927061d20473906accc20c58fcd752bb69261eb0ba91f14b46c7a4bc7e4dc0421e20620f8681b521e590d0ccdac4ff2eee2c59db8 SHA512 dadf0006d0c2740030fafc6379be6faafffef9ca845412cd3d99a36d4142c7565f9c4f6096ea6cf8731dda80c6b98ab3ff164cce891a481f1bb1ebc73ed1c28e
MISC metadata.xml 257 BLAKE2B 65c73e9c8dcc3e61188ef911f456b2ae23c9f2a0a207c7e3075566177dd9ea14b0b2da755fe8b864552179ebc17ff35a12a824c1eae0d52d3ecacf2a5aacf438 SHA512 89f76751a66c20c3d723ab5eb4a547baae7aa155ed5cc0e82c9c78ce6a26a8b51a2025c25b3a2df8e0b67b41e5c7479b8d162111fbd2f0949adecdeb44b5a750
diff --git a/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.0.3.ebuild b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.0.8.ebuild
index 209f68c72490..209f68c72490 100644
--- a/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.0.3.ebuild
+++ b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.0.8.ebuild