summaryrefslogtreecommitdiff
path: root/app-laptop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /app-laptop
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/Manifest.gzbin3234 -> 3234 bytes
-rw-r--r--app-laptop/hdaps-gl/Manifest3
-rw-r--r--app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild32
-rw-r--r--app-laptop/hdaps-gl/metadata.xml11
4 files changed, 41 insertions, 5 deletions
diff --git a/app-laptop/Manifest.gz b/app-laptop/Manifest.gz
index 4cb5f98dc072..2ea9f1c63772 100644
--- a/app-laptop/Manifest.gz
+++ b/app-laptop/Manifest.gz
Binary files differ
diff --git a/app-laptop/hdaps-gl/Manifest b/app-laptop/hdaps-gl/Manifest
index a16009241ff9..80c9861f9085 100644
--- a/app-laptop/hdaps-gl/Manifest
+++ b/app-laptop/hdaps-gl/Manifest
@@ -1,4 +1,5 @@
AUX hdaps-gl-0.0.5-as-needed.diff 346 BLAKE2B 475c8784ee192f632686177b3d4cf25be97260893621b9bfcff2e649d36cdcf1d4059c9c643cf3153daabb234d8520b51f033de471e2b62d9702db0720bc0782 SHA512 6128fb53c82485a7141d7bff95aea3ab6d20593a9c535bee841c22bcba9504bdf3913eff07fab0de3b58225cab60b3a41638b250d37f1a0f4f67d03c02a29716
DIST hdaps-gl-0.0.5.tar.gz 2495 BLAKE2B 00b9b79b906e32b5671ae97c30fe0e3007da8ef809078b664befe46e472af39977f6947dfbde53afee30d42e5b104ba055d5e5412d76263d5741db75c663b308 SHA512 6ebef6324fcdfaf5c2ec6cc8382d376c711e5d957a4ffdd4ee150317649ea0a47552e421f8008a3498ac49487657dca2f49b1a50169d7ab02ee5bef856625d19
+EBUILD hdaps-gl-0.0.5-r1.ebuild 595 BLAKE2B 31dc38e9c70ccd7ed05282729c5488d2ac3451d82f0a35b1a271f8c36096992f66dae207f6efaa334f08db8ab67e6deda603920b1bac490423d568e0447689b2 SHA512 22048ef7f3c786e8bb72e9c0bc480a641c22ed6f4cdc9e650f69afe370012ef0d2d1c104892ec194ead43cd01404b7d53fc850c3149a6d57af9c8001410cfadd
EBUILD hdaps-gl-0.0.5.ebuild 604 BLAKE2B 99848773670133279f29304b88170ecdd66b8e2b5fd01fe41ea9730f577bda063ca513521957741cfd6a719c808e856f8ddd89f0e26445d59e8e1550d2566b69 SHA512 3338f31513e579b73e7ae97eacdcf906076745db0ad01e297114d4db78dcfa8f83a41dec409d77d8cb5d9de84c23b8af282ae62e64bcef0c14b3cf9d1db2c6b4
-MISC metadata.xml 242 BLAKE2B b0338d200d4eb439908bd1e4990832314acd6c02985f36736137c4d7a00e7552f0bd9bc97c20bc3980ceec2551b27278c163711f0af5c6af01bfc52a2cfb8831 SHA512 8376434ff91f5848064ea6c4e040d35ada37f295c0120b65ee9418f6d140ca98a8fb442bdb1e03b292cecc404f323cb9b28ed83da353e5e4dd5eb7f842f2df18
+MISC metadata.xml 331 BLAKE2B b37ad024d05ff927954691e305f0f8db45f7491b26c35c483f12133f6ec1e820113dd8b9f63574abaaec807a0e1b1fc746a9c99350957bb538cda811fdb4551a SHA512 f8c3780b4eccb984b5dca649b55f3e9f00017bb650dfa580c924a0d0e897ddf50c89db9087800a974a37b154b65c412458db01e30585777f71bdfb8dc448ddf6
diff --git a/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild b/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..6e145279052f
--- /dev/null
+++ b/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="OpenGL visualization for HDAPS data"
+HOMEPAGE="http://hdaps.sourceforge.net"
+SRC_URI="mirror://sourceforge/hdaps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND=""
+DEPEND="virtual/opengl
+ media-libs/freeglut"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-as-needed.diff" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin "${PN}"
+}
diff --git a/app-laptop/hdaps-gl/metadata.xml b/app-laptop/hdaps-gl/metadata.xml
index 4d89b7be7780..1b35bde263cc 100644
--- a/app-laptop/hdaps-gl/metadata.xml
+++ b/app-laptop/hdaps-gl/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">hdaps</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">hdaps</remote-id>
+ </upstream>
</pkgmetadata>