summaryrefslogtreecommitdiff
path: root/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-13 05:50:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-13 05:50:34 +0100
commit4b718beb7d5fd4e0b5d741ff3a4c5c570519195e (patch)
treeeb9b412ce4b9457ccbb2a6481d80e5f407fdd499 /app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild
parent241157fae4eae88cefc48b4644bad8b9e53583dc (diff)
gentoo auto-resync : 13:05:2023 - 05:50:34
Diffstat (limited to 'app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild')
-rw-r--r--app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild
new file mode 100644
index 000000000000..b3fce1cb74dc
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+CONFIG_CHECK="ACPI_WMI INPUT_SPARSEKMAP"
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="Kernel Module for Tuxedo Keyboard"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-keyboard"
+SRC_URI="https://github.com/tuxedocomputers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BUILD_TARGETS="all"
+MODULE_NAMES="clevo_acpi(tuxedo:${S}:src) clevo_wmi(tuxedo:${S}:src) uniwill_wmi(tuxedo:${S}:src) tuxedo_keyboard(tuxedo:${S}:src) tuxedo_io(tuxedo:${S}:src/tuxedo_io)"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.2.1-rm-unused-functions.patch )
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KDIR=${KV_DIR} V=1 KBUILD_VERBOSE=1"
+}