summaryrefslogtreecommitdiff
path: root/app-laptop/spicctrl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-laptop/spicctrl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-laptop/spicctrl')
-rw-r--r--app-laptop/spicctrl/Manifest4
-rw-r--r--app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch11
-rw-r--r--app-laptop/spicctrl/metadata.xml5
-rw-r--r--app-laptop/spicctrl/spicctrl-1.9-r1.ebuild28
4 files changed, 48 insertions, 0 deletions
diff --git a/app-laptop/spicctrl/Manifest b/app-laptop/spicctrl/Manifest
new file mode 100644
index 000000000000..54fa1aa8eaef
--- /dev/null
+++ b/app-laptop/spicctrl/Manifest
@@ -0,0 +1,4 @@
+AUX spicctrl-1.9-makefile.patch 284 BLAKE2B 86f2e5f7f5748de8051deb3f94f86c1227416ef23b57e5f8ef9486dccb4a2d080fca3c36ad9aaecf65cd8b48a0ae0eccf37387a4360f021cd9d7a8fcb3c0446d SHA512 65a4dc464660cb7b157f3fd6c17dbd1ef9a1976525e68b3bbab72fbb389cc1ff98da43a7e332be360727852ffa86bd237ef633f8253cb1a731efa91a99e93913
+DIST spicctrl-1.9.tar.bz2 10917 BLAKE2B c26101bb13bd512434b076b9fc6467189c7cb60f7b4a8dd0eede7b18b888d2b418c505896f2b52724df5ea7fab50b336f5843369a9ef4d19e642adc0f8399a01 SHA512 7b1d7862a51dd3321fe84cc5921d71a8f0b978755cbd7c31e54a59ad1c9d3f781d649436bd9b7fba71446a593ad7e925470731f5bd135350942fb0c03fbd4d3e
+EBUILD spicctrl-1.9-r1.ebuild 538 BLAKE2B bb22fb85feae533c67c12d0d51ee30fd5bb08599df03893235db9c4cf4aea3234b5f2e4272796ef34df5ed6aca97129b779f98858a1cdc8313d090aa1fa21ebe SHA512 346ce1707c6c8baeabcbd89415ad8ce395a501fc5fb3ffe9c5c87b128da7737f9d0d6da28d2f2441142e1b340d693c8a8fc3f52b412caadc6d5149d18f4d5da5
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch b/app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch
new file mode 100644
index 000000000000..a49a29c30fb5
--- /dev/null
+++ b/app-laptop/spicctrl/files/spicctrl-1.9-makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2012-11-20 12:38:41.528871594 +0400
++++ Makefile 2012-11-20 12:39:42.630871103 +0400
+@@ -14,7 +14,7 @@
+ all: spicctrl
+
+ spicctrl: $(OBJ)
+- $(CC) -o spicctrl $(OBJ) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o spicctrl $(OBJ) $(LIBS)
+
+ clean:
+ rm -f $(OBJ) spicctrl *~
diff --git a/app-laptop/spicctrl/metadata.xml b/app-laptop/spicctrl/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-laptop/spicctrl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild b/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild
new file mode 100644
index 000000000000..d1aceef29615
--- /dev/null
+++ b/app-laptop/spicctrl/spicctrl-1.9-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit base toolchain-funcs
+
+DESCRIPTION="tool for the sonypi-Device (found in Sony Vaio Notebooks)"
+HOMEPAGE="http://www.popies.net/sonypi/"
+SRC_URI="http://www.popies.net/sonypi/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin spicctrl
+}