summaryrefslogtreecommitdiff
path: root/app-laptop/mbpfan/mbpfan-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-laptop/mbpfan/mbpfan-9999.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-laptop/mbpfan/mbpfan-9999.ebuild')
-rw-r--r--app-laptop/mbpfan/mbpfan-9999.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-laptop/mbpfan/mbpfan-9999.ebuild b/app-laptop/mbpfan/mbpfan-9999.ebuild
deleted file mode 100644
index 357bf95cf287..000000000000
--- a/app-laptop/mbpfan/mbpfan-9999.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit linux-info systemd toolchain-funcs
-
-DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
-HOMEPAGE="https://github.com/dgraziotin/mbpfan"
-LICENSE="GPL-3+"
-SLOT="0"
-RESTRICT="test" # will fail if the hardware is unavailable, not useful
-
-if [[ "${PV}" = 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
-
- # Remove the empty systemd unit directory
- # It doesn't actually install the unit file
- rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
- # Actually install the sytstemd unit file
- systemd_dounit ${PN}.service
- # Install openrc init file
- newinitd ${PN}.init.gentoo ${PN}
-
- # make install doesn't install the docs in the right place
- rm -rf "${ED%/}/usr/share/doc/${PN}" || die
-
- einstalldocs
-}