summaryrefslogtreecommitdiff
path: root/app-laptop/mbpfan/mbpfan-2.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-27 07:34:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-27 07:34:25 +0100
commit61faa1ea0e8302df305bc281038fc00dc7eb1dd4 (patch)
tree80638756ce07f0db3bcdc33653970fa5452df743 /app-laptop/mbpfan/mbpfan-2.2.1-r1.ebuild
parent00757bf15f0eb42661625ed16888d00af9a79561 (diff)
gentoo auto-resync : 27:06:2023 - 07:34:25
Diffstat (limited to 'app-laptop/mbpfan/mbpfan-2.2.1-r1.ebuild')
-rw-r--r--app-laptop/mbpfan/mbpfan-2.2.1-r1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/app-laptop/mbpfan/mbpfan-2.2.1-r1.ebuild b/app-laptop/mbpfan/mbpfan-2.2.1-r1.ebuild
deleted file mode 100644
index 1bbd3102e15e..000000000000
--- a/app-laptop/mbpfan/mbpfan-2.2.1-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-info systemd toolchain-funcs
-
-DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
-HOMEPAGE="https://github.com/dgraziotin/mbpfan"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
-else
- SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-RESTRICT="test" # will fail if the hardware is unavailable, not useful
-
-CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
-
- # Decompress the man page to enable PM auto compression
- gzip -d "${ED}"/usr/share/man/man8/mbpfan.8.gz || die
-
- # Remove the empty systemd unit directory
- # It doesn't actually install the unit file
- rmdir --ignore-fail-on-non-empty -p "${ED}"/lib/systemd/system || die
- # Actually install the sytstemd unit file
- systemd_dounit ${PN}.service
- # Install openrc init file
- newinitd ${PN}.init.gentoo ${PN}
-
- # make install doesn't install the docs in the right place
- rm -r "${ED}"/usr/share/doc/${PN} || die
-
- einstalldocs
-}