summaryrefslogtreecommitdiff
path: root/app-laptop/mbpfan/mbpfan-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /app-laptop/mbpfan/mbpfan-2.0.0.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'app-laptop/mbpfan/mbpfan-2.0.0.ebuild')
-rw-r--r--app-laptop/mbpfan/mbpfan-2.0.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/app-laptop/mbpfan/mbpfan-2.0.0.ebuild b/app-laptop/mbpfan/mbpfan-2.0.0.ebuild
deleted file mode 100644
index fb1fc7c3f9dc..000000000000
--- a/app-laptop/mbpfan/mbpfan-2.0.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit linux-info systemd toolchain-funcs
-
-DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
-HOMEPAGE="https://github.com/dgraziotin/mbpfan"
-LICENSE="GPL-3+"
-SLOT="0"
-RESTRICT="test" # will fail if the hardware is unavailable, not useful
-
-if [[ "${PV}" = 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- # There's a double linking problem in install
- emake DESTDIR="${ED}" CC="$(tc-getCC)" install
-
- # Remove the empty systemd unit directory
- # It doesn't actually install the unit file
- rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
- # Actually install the sytstemd unit file
- systemd_dounit ${PN}.service
- # Install openrc init file
- newinitd ${PN}.init.gentoo ${PN}
-
- # make install doesn't install the docs in the right place
- rm -rf "${ED%/}/usr/share/doc/${PN}" || die
-
- einstalldocs
-}