summaryrefslogtreecommitdiff
path: root/app-laptop/mbpfan/mbpfan-1.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-laptop/mbpfan/mbpfan-1.9.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-laptop/mbpfan/mbpfan-1.9.1.ebuild')
-rw-r--r--app-laptop/mbpfan/mbpfan-1.9.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-laptop/mbpfan/mbpfan-1.9.1.ebuild b/app-laptop/mbpfan/mbpfan-1.9.1.ebuild
new file mode 100644
index 000000000000..58ae75eb0cb0
--- /dev/null
+++ b/app-laptop/mbpfan/mbpfan-1.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+src_prepare() {
+ sed -i -e "s:g++:$(tc-getCXX):g" Makefile || die
+ default
+}
+
+src_install() {
+ dosbin bin/mbpfan
+
+ insinto /etc
+ doins ${PN}.conf
+
+ newinitd ${PN}.init.gentoo ${PN}
+ systemd_dounit ${PN}.service
+
+ einstalldocs
+}