summaryrefslogtreecommitdiff
path: root/app-laptop/ibam/ibam-0.5.2-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-laptop/ibam/ibam-0.5.2-r4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-laptop/ibam/ibam-0.5.2-r4.ebuild')
-rw-r--r--app-laptop/ibam/ibam-0.5.2-r4.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/app-laptop/ibam/ibam-0.5.2-r4.ebuild b/app-laptop/ibam/ibam-0.5.2-r4.ebuild
index 2076603b9f60..25d42e8d7193 100644
--- a/app-laptop/ibam/ibam-0.5.2-r4.ebuild
+++ b/app-laptop/ibam/ibam-0.5.2-r4.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PATCH_LEVEL="2.1"
-
inherit toolchain-funcs
DESCRIPTION="Intelligent Battery Monitor"
@@ -27,20 +26,17 @@ DEPEND="
${RDEPEND}
gkrellm? ( virtual/pkgconfig )"
-src_prepare() {
- eapply \
- "${FILESDIR}"/${P}-build.patch \
- "${WORKDIR}"/${PN}_${PV}-${PATCH_LEVEL}.diff
-
- eapply debian/patches/02*.dpatch
- eapply debian/patches/03*.dpatch
- eapply debian/patches/05*.dpatch
-
- eapply_user
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${WORKDIR}"/${PN}_${PV}-${PATCH_LEVEL}.diff
+ "${S}"/debian/patches/02deviation.dpatch
+ "${S}"/debian/patches/03acpi-check.dpatch
+ "${S}"/debian/patches/05_sysfs_lenovo.dpatch
+)
src_compile() {
- tc-export CXX
+ tc-export CXX PKG_CONFIG
+
emake
use gkrellm && emake krell
}