summaryrefslogtreecommitdiff
path: root/app-laptop/batti
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-laptop/batti
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-laptop/batti')
-rw-r--r--app-laptop/batti/Manifest5
-rw-r--r--app-laptop/batti/batti-0.3.8-r4.ebuild45
-rw-r--r--app-laptop/batti/files/batti-0.3.8-upower-0.99.patch34
-rw-r--r--app-laptop/batti/files/batti-0.3.8-upower-capital.patch32
-rw-r--r--app-laptop/batti/metadata.xml11
5 files changed, 127 insertions, 0 deletions
diff --git a/app-laptop/batti/Manifest b/app-laptop/batti/Manifest
new file mode 100644
index 000000000000..688992daf679
--- /dev/null
+++ b/app-laptop/batti/Manifest
@@ -0,0 +1,5 @@
+AUX batti-0.3.8-upower-0.99.patch 1248 BLAKE2B e653700d3fd4fc07f1344809ae2f7ff7eee449b812d25fca502e573d320456a3a7b3bc018f710ec8fd9e32f480c6ccc0824eef58490a11a057b7e98bea06147e SHA512 172036b2d5f63c37d26a9542e9348b469c2df4e1380fa3ff4c13883e3a295963c569230b32a36eba14f70e37f87dfc2fcfe03e98406a335749f2d0234c5d30be
+AUX batti-0.3.8-upower-capital.patch 1409 BLAKE2B 30f3667c5927986b4dbd63d4beccc9b59506f51bfb1e8cefae5bb59adaae7994bd4a64b6939417b230859967b29ad525a27772979d4bf65d687d4887a9942b3e SHA512 6b0f0fafe7443338b9af69156476fdbe231054010ec1ac17dada5c9f68c23477f50bc32d450cf7b3af5c2d012d3264aff4a74630ea2543e500c1f5c95534f1b6
+DIST batti-0.3.8.tar.gz 59783 BLAKE2B cba35af1d8d3e5f2e44e27eb2727fc2115d89d5ff79bd54f263a25678c4a5d9d87da685905f85c3d47bdeeeba164bb0dce09082adb211acc51a02ec514e0122a SHA512 39e0085a13847359eb555eff80c3f3b166775558fba3c76ecb4315786e2ce4307d21dcac5fab38da4ee3cc2035356906eb1354ced56a1f007735029e0484a4de
+EBUILD batti-0.3.8-r4.ebuild 966 BLAKE2B aa126adc77a05530041fd12b01e7d2cd4b5c956c6f3e3b14f0649589644f2aad6d1352fdce3bedecc890fd18ef80dd645f2d8c0556cb6828b0e7016e47d7df3a SHA512 149e6aedf94fd886c93b1b31d4d52098d655d9b6566477de28f9c0d06b5269080caf74939f6cae7cf927d7ada6516b6d06e69ab90d644f27336b74e1ec6e87b5
+MISC metadata.xml 323 BLAKE2B 9a3aaf09e7b171dcf71d85c4ebd4249059d76a51bdeb036cb919c73fbecfb7aeb884857529ca6c8ba66746369f2113d4077371b28159a81c1d6339d3ff75c4a3 SHA512 7b3c4c3895e87916db14eb4d611dea5be29d2d1846ee9ec47f56abba20b31091c834f3d5562a57b4fb828e2866f9c6e64ba9f57d25bcf7a2195bca2f7363c5aa
diff --git a/app-laptop/batti/batti-0.3.8-r4.ebuild b/app-laptop/batti/batti-0.3.8-r4.ebuild
new file mode 100644
index 000000000000..f4824578587d
--- /dev/null
+++ b/app-laptop/batti/batti-0.3.8-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="A upower based battery monitor for the system tray, similar to batterymon"
+HOMEPAGE="https://code.google.com/p/batti-gtk/"
+SRC_URI="https://batti-gtk.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="libnotify"
+
+RDEPEND="
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ || ( sys-power/upower sys-power/upower-pm-utils )
+ x11-themes/hicolor-icon-theme
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND=""
+
+src_prepare() {
+ default
+ if has_version ">=sys-power/upower-0.99"; then
+ eapply "${FILESDIR}/${P}-upower-0.99.patch"
+ eapply "${FILESDIR}/${P}-upower-capital.patch"
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-laptop/batti/files/batti-0.3.8-upower-0.99.patch b/app-laptop/batti/files/batti-0.3.8-upower-0.99.patch
new file mode 100644
index 000000000000..6f313a594c94
--- /dev/null
+++ b/app-laptop/batti/files/batti-0.3.8-upower-0.99.patch
@@ -0,0 +1,34 @@
+diff -Naur batti-0.3.8.orig/src/PowerBackend.py batti-0.3.8/src/PowerBackend.py
+--- batti-0.3.8.orig/src/PowerBackend.py 2014-04-15 19:30:34.123260000 +0200
++++ batti-0.3.8/src/PowerBackend.py 2014-04-15 19:32:11.859168509 +0200
+@@ -180,17 +180,6 @@
+
+ properties = dbus.Interface(iface, 'org.freedesktop.DBus.Properties')
+
+- if properties.Get(self.dbus_interface, 'CanSuspend'):
+- self.__can_suspend = True
+- else:
+- self.__can_suspend = False
+-
+- if properties.Get(self.dbus_interface, 'CanHibernate'):
+- self.__can_hibernate = True
+- else:
+- self.__can_hibernate = False
+-
+-
+ def __get_interface(self):
+ dkit_obj = self.__bus.get_object(self.dbus_service, self.dbus_object)
+ return dbus.Interface(dkit_obj, self.dbus_interface)
+@@ -201,12 +190,6 @@
+ self.__mc_action(widget, event, data)
+
+
+- def can_suspend(self):
+- return self.__can_suspend and self.__get_interface().SuspendAllowed()
+-
+- def can_hibernate(self):
+- return self.__can_hibernate and self.__get_interface().HibernateAllowed()
+-
+ def suspend(self):
+ self.__get_interface().Suspend()
+
diff --git a/app-laptop/batti/files/batti-0.3.8-upower-capital.patch b/app-laptop/batti/files/batti-0.3.8-upower-capital.patch
new file mode 100644
index 000000000000..e7f62761661c
--- /dev/null
+++ b/app-laptop/batti/files/batti-0.3.8-upower-capital.patch
@@ -0,0 +1,32 @@
+From 1e0fe57a93ed3996bad295e20eeda81f6af483af Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Wed, 20 Jul 2016 20:14:32 +0200
+Subject: [PATCH] The type property (in recent UPower at least) needs to have a
+ capital T - "Type"
+
+---
+ src/PowerBackend.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/PowerBackend.py b/src/PowerBackend.py
+index e020b98..56bcb61 100644
+--- a/src/PowerBackend.py
++++ b/src/PowerBackend.py
+@@ -165,7 +165,7 @@ def __init__(self):
+ self.__batteries = {}
+ for dev in devices:
+ (prop_iface, dev_iface) = self.__get_battery(dev)
+- type = prop_iface.Get(self.device_interface, 'type')
++ type = prop_iface.Get(self.device_interface, 'Type')
+ if type == self.bat_type:
+ power_bat = UPowerBattery(prop_iface, dev_iface)
+ self.__batteries[dev] = power_bat
+@@ -228,7 +228,7 @@ def set_right_popup_menu_action(self, action):
+ def __device_added(self, udi):
+ (prop_iface, dev_iface) = self.__get_battery(udi)
+ try:
+- type = prop_iface.Get(self.device_interface, 'type')
++ type = prop_iface.Get(self.device_interface, 'Type')
+ if type == self.bat_type:
+ power_bat = UPowerBattery(prop_iface, dev_iface)
+ power_bat.set_left_popup_menu_action(self.__mc_action)
diff --git a/app-laptop/batti/metadata.xml b/app-laptop/batti/metadata.xml
new file mode 100644
index 000000000000..c26d102ee702
--- /dev/null
+++ b/app-laptop/batti/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>naota@gentoo.org</email>
+ <name>Naohiro Aota</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">batti-gtk</remote-id>
+ </upstream>
+</pkgmetadata>