summaryrefslogtreecommitdiff
path: root/app-i18n
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-07 13:06:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-07 13:06:42 +0000
commit1b97f0352e38f8346984329b82a8be71632220a6 (patch)
treea2eedd48c9161522b87c70d55cbb7d28d2cb36a9 /app-i18n
parenta03bc69159ecc073f051ca2079848553a8e34664 (diff)
gentoo auto-resync : 07:03:2024 - 13:06:41
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/Manifest.gzbin18373 -> 18381 bytes
-rw-r--r--app-i18n/libhangul/Manifest3
-rw-r--r--app-i18n/libhangul/libhangul-0.1.0-r1.ebuild43
-rw-r--r--app-i18n/libhangul/libhangul-0.1.0.ebuild7
-rw-r--r--app-i18n/scim-tomoe/Manifest2
-rw-r--r--app-i18n/scim-tomoe/scim-tomoe-0.6.0-r4.ebuild (renamed from app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild)16
6 files changed, 66 insertions, 5 deletions
diff --git a/app-i18n/Manifest.gz b/app-i18n/Manifest.gz
index c90eb9257948..d1b118e63125 100644
--- a/app-i18n/Manifest.gz
+++ b/app-i18n/Manifest.gz
Binary files differ
diff --git a/app-i18n/libhangul/Manifest b/app-i18n/libhangul/Manifest
index f166a3d1bd85..7d3f5b394e93 100644
--- a/app-i18n/libhangul/Manifest
+++ b/app-i18n/libhangul/Manifest
@@ -1,3 +1,4 @@
DIST libhangul-0.1.0.tar.gz 2899845 BLAKE2B 5d6f4f9d6dfc32b8d6c6c0219b6e25b9c483555dbe623e5d284043d15eb24b4c7044003bcfd4c55b1ff6ab4b3b0c28037a8497f79fc9b733eb7de8952fee3ed0 SHA512 cf84850bf7a41e743457300513c5efdf7b3e18d168f4fdc324aaa8e1be78743752fcb98385764f94c707777ab82cc9444e076808e61fdbd915c9c0d7ea93c534
-EBUILD libhangul-0.1.0.ebuild 832 BLAKE2B f9223cd4dd0b65bd1806087d34a546c3edf08388f574dd1b5238baaf22830aa78279a2e507ab09165fb36780e3fcec9944b51dca3657f9a941355d39e1c18fc0 SHA512 74e9eac3274aa89bfe8c991ae63297a073933e77ed5ee27fddb78265745eca3d5d90383576fdc3de6d24253dbb45784e314f34ccacf4b269ce41b1b5ebcf066e
+EBUILD libhangul-0.1.0-r1.ebuild 894 BLAKE2B 474b76f8e04ef834469d10f25edd00568486b55f9d5fe870d536bf0c5e9b5135dad8d87db5fece9b6e132571247b85c921c62671122a73a5b3e93ba0ffdd5c56 SHA512 efda3c05a7d6b59111353f3ecafe2f72dd3474040a25d8b0da34c772da2028ddcbbdff7d5623f06e7c8c7dd75668191f2ba5b030f40b9dcb59431e431e932e08
+EBUILD libhangul-0.1.0.ebuild 890 BLAKE2B c724a576738b59e498d6139d384adca83e5fd5ff7b53dbb5b367f333a3bb04259a45c8600718f98fe352b33a0a2efda329d19e65751141d7e6d3646edf8415d6 SHA512 1591703557e249822ed0afd5b05d71b7e0b5ccee5314a01815b1e5ce7ba7d1ccdf41bd8a953d135a4448ad2d4ec3452218ea86260eb5114e4d57c550a675b862
MISC metadata.xml 521 BLAKE2B 1c1aab288333ba0d459f22f0a19e3ecea24d31f04937490c3ce68f80020ca4b00ebd77c7ad7326a4f1b9422b4792bfc572326c5fab277f671d44b2f2eed6cbfa SHA512 a011481897d3b89ae414405bdf9e5f34ad0542d5ae295e23711666d42c3fc0e097a8826d186c37ab77d3a622868bd2d273b8e9d7fb4f0960a3d88199b3d410c6
diff --git a/app-i18n/libhangul/libhangul-0.1.0-r1.ebuild b/app-i18n/libhangul/libhangul-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..5e8906a50a01
--- /dev/null
+++ b/app-i18n/libhangul/libhangul-0.1.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2006-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit libtool
+
+DESCRIPTION="Library for hangul input method logic, hanja dictionary"
+HOMEPAGE="https://github.com/libhangul/libhangul"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="nls static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ emake -C test check
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}
diff --git a/app-i18n/libhangul/libhangul-0.1.0.ebuild b/app-i18n/libhangul/libhangul-0.1.0.ebuild
index f7322859e1e9..8f6b101fa56f 100644
--- a/app-i18n/libhangul/libhangul-0.1.0.ebuild
+++ b/app-i18n/libhangul/libhangul-0.1.0.ebuild
@@ -3,6 +3,8 @@
EAPI="7"
+inherit libtool
+
DESCRIPTION="Library for hangul input method logic, hanja dictionary"
HOMEPAGE="https://github.com/libhangul/libhangul"
SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
@@ -20,6 +22,11 @@ RDEPEND="virtual/libiconv
DEPEND="${RDEPEND}
test? ( dev-libs/check )"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf \
$(use_enable nls) \
diff --git a/app-i18n/scim-tomoe/Manifest b/app-i18n/scim-tomoe/Manifest
index a942f5a9ec1a..c26057d0ef62 100644
--- a/app-i18n/scim-tomoe/Manifest
+++ b/app-i18n/scim-tomoe/Manifest
@@ -1,4 +1,4 @@
AUX scim-tomoe-0.6.0-gcc43.patch 445 BLAKE2B 7a6f48120398dd661a647914e9097dc69807a2c0d18ba9c56517c48df2a67dd7406cb13dea283ff5b9b8c64a19dcff4548453f0c47cb37f890cef0cf7a1794a8 SHA512 a27202fdf5be0d77d473674475ee99d2b0d1a6eba51ccc45c4c7dc6c3a9c3d1042ed3b25ae15a04fcff885aad7b84c42cac7462fcc739bf12076e675b413fafa
DIST scim-tomoe-0.6.0.tar.gz 385126 BLAKE2B e211c97caab5221d80541cbc795d3559b9843df4fb03bc559a20dc34b510288aefde87251c35c0a123501192d8f4ffb9209fa3c6c74acbbba75ae3321dd58fe9 SHA512 d70a8838f8c82c76a8e3592ad712997189873cbc4ec7ebeba5d43d6583e24acf318299433c9342ee004c4ae4741cca7e0b88e4642cf46c43f967a47ec5ac9d4f
-EBUILD scim-tomoe-0.6.0-r3.ebuild 637 BLAKE2B 6ca0ea9f48f44c3b3d638af9a3efb06ca4e5da9b6bfba361b334fe976b8b3fed0c6fac4a553b210ed38be0b82ea3cc029645738b788945914c012584bd018c20 SHA512 55ae40dfe0fdcca9146e0b256bf4cc855ae2d4bc5fcf9a0d6afbaef4d2cc1e2c168d74168e904a7434e17cbf475ca19afc367fee1aa2425285dac051fa749e32
+EBUILD scim-tomoe-0.6.0-r4.ebuild 798 BLAKE2B a7b526c5ff8cf69b4f09be232831a75e47709fb587aa3e19948d0456bde97fb035a0a4c19b726598b1a379c4cc1bb561377c1e069708990864877c218648a6bc SHA512 777be44683dc3d8bd7c3742423948089f2fdc0de7a0b990314730fdf7f108d068c9e20d65ecea4de0b18e1d5c58f582b6661720e58d081dc81b1baa011b97568
MISC metadata.xml 310 BLAKE2B fc9dca325196e8ffcfca49c336d9d2bcc851a6c33e69ede9c8ed9d3bd1dac72d290dfabc7fecee3cc92259f6cc9a0c875d4a75dcd14d04e8e90acf287fba4e2f SHA512 682ac49db6b852d1221aca3b03b653a37a90efc10313c4c422cd86a6aa63d4ffedbd58848e71635fb7e763f70e7899a8eb17d3a0d4df3bf944f8293c2e046e6b
diff --git a/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r4.ebuild
index c6c427a16733..21e635c5dee0 100644
--- a/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild
+++ b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r4.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit autotools
DESCRIPTION="Japanese input method Tomoe IMEngine for SCIM"
HOMEPAGE="http://tomoe.sourceforge.net/"
@@ -16,14 +18,22 @@ RDEPEND="
>=app-i18n/scim-1.2.0
>=app-i18n/tomoe-gtk-0.6.0
>=x11-libs/gtk+-2.4:2
+ dev-libs/libltdl
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
>=dev-util/intltool-0.35.0
"
PATCHES=( "${FILESDIR}"/${P}-gcc43.patch )
+src_prepare() {
+ default
+ # update the 2007 era configure / libtool scripts, which fail with LTO
+ eautoreconf
+}
+
src_configure() {
econf --disable-static
}