summaryrefslogtreecommitdiff
path: root/app-i18n/uim/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/uim/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/uim/files')
-rw-r--r--app-i18n/uim/files/50uim-gentoo.el2
-rw-r--r--app-i18n/uim/files/uim-1.8.6-gentoo.patch28
-rw-r--r--app-i18n/uim/files/uim-1.8.6-libressl.patch79
-rw-r--r--app-i18n/uim/files/uim-1.8.6-qt.patch16
-rw-r--r--app-i18n/uim/files/uim-1.8.6-tinfo.patch65
-rw-r--r--app-i18n/uim/files/uim-gentoo.patch28
-rw-r--r--app-i18n/uim/files/uim-tinfo.patch38
-rw-r--r--app-i18n/uim/files/uim-zh-TW.patch11
-rw-r--r--app-i18n/uim/files/xinput-uim6
9 files changed, 273 insertions, 0 deletions
diff --git a/app-i18n/uim/files/50uim-gentoo.el b/app-i18n/uim/files/50uim-gentoo.el
new file mode 100644
index 000000000000..101505c4bd59
--- /dev/null
+++ b/app-i18n/uim/files/50uim-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'uim-mode "uim" nil t)
diff --git a/app-i18n/uim/files/uim-1.8.6-gentoo.patch b/app-i18n/uim/files/uim-1.8.6-gentoo.patch
new file mode 100644
index 000000000000..0feee5a70997
--- /dev/null
+++ b/app-i18n/uim/files/uim-1.8.6-gentoo.patch
@@ -0,0 +1,28 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -36,6 +36,7 @@
+ AC_PATH_PROGS(SHA1, sha1 sha1sum)
+ AC_PATH_PROGS(SED, sed gsed)
+ AX_PATH_QMAKE4
++PKG_PROG_PKG_CONFIG
+
+ AM_MAINTAINER_MODE
+
+@@ -1792,7 +1793,7 @@
+ fi
+ AX_LANG_WNOERROR # end AC_LANG_WERROR
+
+- QT_CONFIG_OPTS="debug"
++ QT_CONFIG_OPTS="debug nostrip"
+ else
+ CFLAGS="$CFLAGS -DNDEBUG"
+ CXXFLAGS="$CXXFLAGS -DNDEBUG"
+@@ -1810,7 +1811,7 @@
+ AX_CFLAGS_GCC_OPTION([-Wno-unused-variable], [SCIM_CFLAGS])
+ AX_LANG_WNOERROR # end AC_LANG_WERROR
+
+- QT_CONFIG_OPTS="release"
++ QT_CONFIG_OPTS="release nostrip"
+ fi
+
+ AC_ARG_ENABLE(warnings-into-error,
diff --git a/app-i18n/uim/files/uim-1.8.6-libressl.patch b/app-i18n/uim/files/uim-1.8.6-libressl.patch
new file mode 100644
index 000000000000..b14de58433aa
--- /dev/null
+++ b/app-i18n/uim/files/uim-1.8.6-libressl.patch
@@ -0,0 +1,79 @@
+From 7a281b1131399f04627986e6f9a54499b08e239d Mon Sep 17 00:00:00 2001
+From: Felix Janda <felix.janda@posteo.de>
+Date: Thu, 21 Apr 2016 23:12:10 +0200
+Subject: [PATCH] Make openssl SSLv2 and SSLv3 support optional
+
+Fixes compilation with libressl
+---
+ uim/openssl.c | 30 ++++++++++++++++++++++++++++++
+ 1 file changed, 30 insertions(+)
+
+diff --git a/uim/openssl.c b/uim/openssl.c
+index ba1b238..35ca1ca 100644
+--- a/uim/openssl.c
++++ b/uim/openssl.c
+@@ -208,34 +208,64 @@ c_SSL_write(uim_lisp s_, uim_lisp buf_)
+ static uim_lisp
+ c_SSLv2_method(void)
+ {
++#ifndef OPENSSL_NO_SSL2
+ return MAKE_PTR(SSLv2_method());
++#else
++ uim_notify_fatal(N_("uim-openssl: SSLv2_method() is not supported on this system"));
++ return uim_scm_f();
++#endif
+ }
+ static uim_lisp
+ c_SSLv2_server_method(void)
+ {
++#ifndef OPENSSL_NO_SSL2
+ return MAKE_PTR(SSLv2_server_method());
++#else
++ uim_notify_fatal(N_("uim-openssl: SSLv2_server_method() is not supported on this system"));
++ return uim_scm_f();
++#endif
+ }
+ static uim_lisp
+ c_SSLv2_client_method(void)
+ {
++#ifndef OPENSSL_NO_SSL2
+ return MAKE_PTR(SSLv2_client_method());
++#else
++ uim_notify_fatal(N_("uim-openssl: SSLv2_client_method() is not supported on this system"));
++ return uim_scm_f();
++#endif
+ }
+
+ /* SSLv3 */
+ static uim_lisp
+ c_SSLv3_method(void)
+ {
++#ifndef OPENSSL_NO_SSL3
+ return MAKE_PTR(SSLv3_method());
++#else
++ uim_notify_fatal(N_("uim-openssl: SSLv3_method() is not supported on this system"));
++ return uim_scm_f();
++#endif
+ }
+ static uim_lisp
+ c_SSLv3_server_method(void)
+ {
++#ifndef OPENSSL_NO_SSL3
+ return MAKE_PTR(SSLv3_server_method());
++#else
++ uim_notify_fatal(N_("uim-openssl: SSLv3_server_method() is not supported on this system"));
++ return uim_scm_f();
++#endif
+ }
+ static uim_lisp
+ c_SSLv3_client_method(void)
+ {
++#ifndef OPENSSL_NO_SSL3
+ return MAKE_PTR(SSLv3_client_method());
++#else
++ uim_notify_fatal(N_("uim-openssl: SSLv3_client_method() is not supported on this system"));
++ return uim_scm_f();
++#endif
+ }
+
+ /* SSLv3 but can rollback to v2 */
diff --git a/app-i18n/uim/files/uim-1.8.6-qt.patch b/app-i18n/uim/files/uim-1.8.6-qt.patch
new file mode 100644
index 000000000000..6c0cb7eee667
--- /dev/null
+++ b/app-i18n/uim/files/uim-1.8.6-qt.patch
@@ -0,0 +1,16 @@
+--- a/m4/ax_path_qmake4.m4
++++ b/m4/ax_path_qmake4.m4
+@@ -23,10 +23,10 @@
+ # the copyright notice and this notice are preserved.
+
+ AC_DEFUN([AX_PATH_QMAKE4], [
+- ax_guessed_qt4_dirs="/usr/lib/qt4/bin:/usr/local/lib/qt4/bin:/usr/qt4/bin:/usr/local/qt4/bin:${QT4DIR}/bin:${QTDIR}/bin"
++ ax_guessed_qt4_dirs="${QT4DIR}/bin:${QTDIR}/bin"
+ AC_PROG_EGREP
+- AC_PATH_PROGS(_QMAKE4, [qmake-qt4 qmake4], [], ["$PATH:$ax_guessed_qt4_dirs"])
+- AC_PATH_PROGS(_QMAKE, [qmake], [], ["$PATH:$ax_guessed_qt4_dirs"])
++ AC_PATH_PROGS(_QMAKE4, [qmake-qt4 qmake4], [], ["$ax_guessed_qt4_dirs:$PATH"])
++ AC_PATH_PROGS(_QMAKE, [qmake], [], ["$ax_guessed_qt4_dirs:$PATH"])
+
+ AC_CACHE_CHECK([for Qt4 version of qmake], ax_cv_path_QMAKE4, [
+ ax_cv_path_QMAKE4=no
diff --git a/app-i18n/uim/files/uim-1.8.6-tinfo.patch b/app-i18n/uim/files/uim-1.8.6-tinfo.patch
new file mode 100644
index 000000000000..51105c909f54
--- /dev/null
+++ b/app-i18n/uim/files/uim-1.8.6-tinfo.patch
@@ -0,0 +1,65 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1058,27 +1058,25 @@
+ ;;
+ yes|*)
+ use_uim_fep="yes"
+- AC_CHECK_LIB(curses, setupterm, FEP_LIBADD="-lcurses $FEP_LIBADD",
+- [AC_CHECK_LIB(ncurses, setupterm, FEP_LIBADD="-lncurses $FEP_LIBADD",
+- AC_MSG_WARN([fep needs setupterm in libcurses or libncurses. disabled...]);use_uim_fep="no")])
+- AC_CHECK_FUNCS(forkpty)
+- if test $ac_cv_func_forkpty = no; then
+- AC_CHECK_LIB(util, forkpty, [AC_DEFINE(HAVE_FORKPTY) FEP_LIBADD="-lutil $FEP_LIBADD"])
+- fi
+- AC_SUBST(FEP_LIBADD)
+ ;;
+ esac
+ ],
+- [ use_uim_fep="yes"
+- AC_CHECK_LIB(curses, setupterm, FEP_LIBADD="-lcurses $FEP_LIBADD",
+- [AC_CHECK_LIB(ncurses, setupterm, FEP_LIBADD="-lncurses $FEP_LIBADD",
+- AC_MSG_WARN([fep needs setupterm in libcurses or libncurses. disabled...]);use_uim_fep="no")])
+- AC_CHECK_FUNCS(forkpty)
+- if test $ac_cv_func_forkpty = no; then
+- AC_CHECK_LIB(util, forkpty, [AC_DEFINE(HAVE_FORKPTY) FEP_LIBADD="-lutil $FEP_LIBADD"])
+- fi
+- AC_SUBST(FEP_LIBADD)
+- ])
++ [use_uim_fep="yes"])
++
++if test "x$use_uim_fep" != "xno"; then
++ PKG_CHECK_MODULES(CURSES, ncurses,
++ [FEP_LIBADD="$CURSES_LIBS $FEP_LIBADD"],
++ [
++ AC_CHECK_LIB(curses, setupterm, FEP_LIBADD="-lcurses $FEP_LIBADD",
++ [AC_CHECK_LIB(ncurses, setupterm, FEP_LIBADD="-lncurses $FEP_LIBADD",
++ AC_MSG_WARN([fep needs setupterm in libcurses or libncurses. disabled...]);use_uim_fep="no")])
++ ])
++ AC_CHECK_FUNCS(forkpty)
++ if test $ac_cv_func_forkpty = no; then
++ AC_CHECK_LIB(util, forkpty, [AC_DEFINE(HAVE_FORKPTY) FEP_LIBADD="-lutil $FEP_LIBADD"])
++ fi
++ AC_SUBST(FEP_LIBADD)
++fi
+
+ AC_ARG_ENABLE(emacs,
+ AC_HELP_STRING([--disable-emacs],
+@@ -1210,10 +1208,14 @@
+ saved_LDFLAGS=$LDFLAGS
+ CPPFLAGS="${CPPFLAGS} -I$libedit_path/include"
+ LDFLAGS="${LDFLAGS} -L$libedit_path/lib"
+- AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
+- [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
+- AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
+- use_libedit="no")])
++ PKG_CHECK_MODULES(CURSES, ncurses,
++ [LIBEDIT_LIBS="$CURSES_LIBS"],
++ [
++ AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
++ [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
++ AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
++ use_libedit="no")])
++ ])
+ if test "x$use_libedit" != "xno"; then
+ AC_CHECK_LIB(edit, el_init,
+ [LIBEDIT_LIBS="-ledit $LIBEDIT_LIBS -L$libedit_path/lib"
diff --git a/app-i18n/uim/files/uim-gentoo.patch b/app-i18n/uim/files/uim-gentoo.patch
new file mode 100644
index 000000000000..de498b754d86
--- /dev/null
+++ b/app-i18n/uim/files/uim-gentoo.patch
@@ -0,0 +1,28 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,6 +38,7 @@
+ AC_PATH_PROGS(SED, sed gsed)
+ AX_PATH_QMAKE4
+ AX_PATH_QMAKE5
++PKG_PROG_PKG_CONFIG
+
+ AM_MAINTAINER_MODE
+
+@@ -1618,7 +1619,7 @@
+ fi
+ AX_LANG_WNOERROR # end AC_LANG_WERROR
+
+- QT_CONFIG_OPTS="debug"
++ QT_CONFIG_OPTS="debug nostrip"
+ else
+ CFLAGS="$CFLAGS -DNDEBUG"
+ CXXFLAGS="$CXXFLAGS -DNDEBUG"
+@@ -1629,7 +1630,7 @@
+ AX_CFLAGS_GCC_OPTION([-Wno-unused-function], [UIM_SCM_CFLAGS])
+ AX_LANG_WNOERROR # end AC_LANG_WERROR
+
+- QT_CONFIG_OPTS="release"
++ QT_CONFIG_OPTS="release nostrip"
+ fi
+
+ AC_ARG_ENABLE(warnings-into-error,
diff --git a/app-i18n/uim/files/uim-tinfo.patch b/app-i18n/uim/files/uim-tinfo.patch
new file mode 100644
index 000000000000..e2fcfceb3158
--- /dev/null
+++ b/app-i18n/uim/files/uim-tinfo.patch
@@ -0,0 +1,38 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1180,9 +1180,13 @@
+
+ if test "x$enable_fep" != xno; then
+ enable_fep=yes
+- AC_CHECK_LIB(curses, setupterm, FEP_LIBADD="-lcurses $FEP_LIBADD",
+- [AC_CHECK_LIB(ncurses, setupterm, FEP_LIBADD="-lncurses $FEP_LIBADD",
+- AC_MSG_WARN([fep needs setupterm in libcurses or libncurses. disabled...]);enable_fep=no)])
++ PKG_CHECK_MODULES(CURSES, ncurses,
++ [FEP_LIBADD="$CURSES_LIBS $FEP_LIBADD"],
++ [
++ AC_CHECK_LIB(curses, setupterm, FEP_LIBADD="-lcurses $FEP_LIBADD",
++ [AC_CHECK_LIB(ncurses, setupterm, FEP_LIBADD="-lncurses $FEP_LIBADD",
++ AC_MSG_WARN([fep needs setupterm in libcurses or libncurses. disabled...]);enable_fep=no)])
++ ])
+ AC_CHECK_FUNCS(forkpty)
+ if test "x$ac_cv_func_forkpty" = xno; then
+ AC_CHECK_LIB(util, forkpty,
+@@ -1319,10 +1323,14 @@
+ saved_LDFLAGS=$LDFLAGS
+ CPPFLAGS="${CPPFLAGS} -I$libedit_path/include"
+ LDFLAGS="${LDFLAGS} -L$libedit_path/lib"
+- AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
+- [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
+- AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
+- with_libedit=no)])
++ PKG_CHECK_MODULES(CURSES, ncurses,
++ [LIBEDIT_LIBS="$CURSES_LIBS"],
++ [
++ AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
++ [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
++ AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
++ with_libedit=no)])
++ ])
+
+ if test "x$with_libedit" != xno; then
+ AC_CHECK_LIB(edit, el_init,
diff --git a/app-i18n/uim/files/uim-zh-TW.patch b/app-i18n/uim/files/uim-zh-TW.patch
new file mode 100644
index 000000000000..f73850013178
--- /dev/null
+++ b/app-i18n/uim/files/uim-zh-TW.patch
@@ -0,0 +1,11 @@
+--- a/xim/convdisp.cpp
++++ b/xim/convdisp.cpp
+@@ -69,7 +69,7 @@
+ #endif
+
+ const char *fontset_zhCN = "-sony-fixed-medium-r-normal--16-*-*-*-c-80-iso8859-1, -isas-fangsong ti-medium-r-normal--16-160-72-72-c-160-gb2312.1980-0";
+-const char *fontset_zhTW = "-sony-fixed-medium-r-normal--16-*-*-*-c-80-iso8859-1, -taipei-fixed-medium-r-normal--16-150-75-75-c-160-big5-0";
++const char *fontset_zhTW = "-sony-fixed-medium-r-normal--16-*-*-*-c-80-iso8859-1, -eten-fixed-medium-r-normal--16-150-75-75-c-160-big5.eten-0";
+ const char *fontset_ja = "-sony-fixed-medium-r-normal--16-*-*-*-c-80-iso8859-1, -jis-fixed-medium-r-normal--16-*-75-75-c-160-jisx0208.1983-0, -sony-fixed-medium-r-normal--16-*-*-*-c-80-jisx0201.1976-0";
+ const char *fontset_ko = "-sony-fixed-medium-r-normal--16-*-*-*-c-80-iso8859-1, -daewoo-gothic-medium-r-normal--16-120-100-100-c-160-ksc5601.1987-0";
+
diff --git a/app-i18n/uim/files/xinput-uim b/app-i18n/uim/files/xinput-uim
new file mode 100644
index 000000000000..a0969dd9f01a
--- /dev/null
+++ b/app-i18n/uim/files/xinput-uim
@@ -0,0 +1,6 @@
+XIM=uim
+XIM_PROGRAM="@EPREFIX@/usr/bin/uim-xim"
+XIM_ARGS=
+GTK_IM_MODULE=uim
+QT_IM_MODULE=uim
+SHORT_DESC=UIM