summaryrefslogtreecommitdiff
path: root/app-i18n/uchardet/uchardet-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-i18n/uchardet/uchardet-9999.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-i18n/uchardet/uchardet-9999.ebuild')
-rw-r--r--app-i18n/uchardet/uchardet-9999.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/app-i18n/uchardet/uchardet-9999.ebuild b/app-i18n/uchardet/uchardet-9999.ebuild
index 0aef01cb3c64..031c6d829482 100644
--- a/app-i18n/uchardet/uchardet-9999.ebuild
+++ b/app-i18n/uchardet/uchardet-9999.ebuild
@@ -1,13 +1,19 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake
+if [ "${PV}" = 9999 ]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
+else
+ SRC_URI="https://www.freedesktop.org/software/uchardet/releases/${P}.tar.xz"
+fi
DESCRIPTION="An encoding detector library"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
SLOT="0"
@@ -16,7 +22,7 @@ IUSE="cpu_flags_x86_sse2 static-libs test"
RESTRICT="!test? ( test )"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
use test || cmake_comment_add_subdirectory test
}
@@ -26,5 +32,5 @@ src_configure() {
-DBUILD_STATIC=$(usex static-libs)
-DCHECK_SSE2=$(usex cpu_flags_x86_sse2)
)
- cmake-utils_src_configure
+ cmake_src_configure
}