summaryrefslogtreecommitdiff
path: root/app-i18n/skkfep/skkfep-0.87-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/skkfep/skkfep-0.87-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/skkfep/skkfep-0.87-r1.ebuild')
-rw-r--r--app-i18n/skkfep/skkfep-0.87-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-i18n/skkfep/skkfep-0.87-r1.ebuild b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
new file mode 100644
index 000000000000..a74c53e6af37
--- /dev/null
+++ b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A SKK-like Japanese input method for console"
+HOMEPAGE="http://aitoweb.world.coocan.jp/soft.html"
+SRC_URI="http://aitoweb.world.coocan.jp/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="sys-apps/sed
+ sys-libs/ncurses:=
+ virtual/awk"
+RDEPEND="sys-libs/ncurses:=
+ app-i18n/skk-jisyo"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-system-dic.patch
+ "${FILESDIR}"/${PN}-annotation.patch
+)
+DOCS=( README HISTORY TODO )
+
+src_prepare() {
+ sed -i "/SYSTEM_DIC_NAME/a#define SYSTEM_DIC_NAME \"${EPREFIX}/usr/share/skk/SKK-JISYO.L\"" config.h
+
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ OPTIMIZE="${CFLAGS}"
+}
+
+src_install() {
+ dobin skkfep escmode
+ doman skkfep.1
+ einstalldocs
+}