summaryrefslogtreecommitdiff
path: root/app-i18n/skkfep/skkfep-0.87-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-i18n/skkfep/skkfep-0.87-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-i18n/skkfep/skkfep-0.87-r1.ebuild')
-rw-r--r--app-i18n/skkfep/skkfep-0.87-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-i18n/skkfep/skkfep-0.87-r1.ebuild b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
new file mode 100644
index 000000000000..a74c53e6af37
--- /dev/null
+++ b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A SKK-like Japanese input method for console"
+HOMEPAGE="http://aitoweb.world.coocan.jp/soft.html"
+SRC_URI="http://aitoweb.world.coocan.jp/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="sys-apps/sed
+ sys-libs/ncurses:=
+ virtual/awk"
+RDEPEND="sys-libs/ncurses:=
+ app-i18n/skk-jisyo"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-system-dic.patch
+ "${FILESDIR}"/${PN}-annotation.patch
+)
+DOCS=( README HISTORY TODO )
+
+src_prepare() {
+ sed -i "/SYSTEM_DIC_NAME/a#define SYSTEM_DIC_NAME \"${EPREFIX}/usr/share/skk/SKK-JISYO.L\"" config.h
+
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ OPTIMIZE="${CFLAGS}"
+}
+
+src_install() {
+ dobin skkfep escmode
+ doman skkfep.1
+ einstalldocs
+}