summaryrefslogtreecommitdiff
path: root/app-i18n/skkfep/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-i18n/skkfep/files
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/skkfep/files')
-rw-r--r--app-i18n/skkfep/files/skkfep-annotation.patch29
-rw-r--r--app-i18n/skkfep/files/skkfep-gentoo.patch75
-rw-r--r--app-i18n/skkfep/files/skkfep-system-dic.patch13
3 files changed, 0 insertions, 117 deletions
diff --git a/app-i18n/skkfep/files/skkfep-annotation.patch b/app-i18n/skkfep/files/skkfep-annotation.patch
deleted file mode 100644
index 8145c2b069e0..000000000000
--- a/app-i18n/skkfep/files/skkfep-annotation.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/kkconv.c
-+++ b/kkconv.c
-@@ -645,6 +645,7 @@
- char c;
- {
- int l;
-+ char *p;
- DicList dlist;
-
- kanjiSelectionEffect(0);
-@@ -653,7 +654,17 @@
- if (OkuriInput)
- l += strlen(OkuriBuf);
- csrLeft(l);
-- writeShells(CurrentCand->candword);
-+ p= strrchr(CurrentCand->candword,';');
-+ if (p != NULL) {
-+ erase(l);
-+ csrLeft(l);
-+ l -= strlen(p);
-+ *p = '\0';
-+ writeShells(CurrentCand->candword);
-+ *p = ';';
-+ } else {
-+ writeShells(CurrentCand->candword);
-+ }
- if (OkuriInput) {
- writeShells(OkuriBuf);
- }
diff --git a/app-i18n/skkfep/files/skkfep-gentoo.patch b/app-i18n/skkfep/files/skkfep-gentoo.patch
deleted file mode 100644
index 2afe3537361e..000000000000
--- a/app-i18n/skkfep/files/skkfep-gentoo.patch
+++ /dev/null
@@ -1,75 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -2,16 +2,16 @@
- # Makefile for skkfep
- #
- all: genMakefile
-- make -f genMakefile all
-+ $(MAKE) -f genMakefile all
-
- skkfep: genMakefile
-- make -f genMakefile skkfep
-+ $(MAKE) -f genMakefile skkfep
-
- simpledic: genMakefile
-- make -f genMakefile simpledic
-+ $(MAKE) -f genMakefile simpledic
-
- clean: genMakefile
-- make -f genMakefile clean
-+ $(MAKE) -f genMakefile clean
- rm -f genMakefile
-
- genMakefile: protoMakefile config.h
---- a/config.h
-+++ b/config.h
-@@ -14,7 +14,7 @@
- #define DEFAULT_KANAKEY "^j"
-
- /* By Y. Kaneko */
--/*#define KUTOUTEN /* "."->maru, ","->ten */
-+#define KUTOUTEN /* "."->maru, ","->ten */
-
- #define KANJIBS /* do/don't shuft-out BS code in JIS mode */
- #define KANJIBS_DEFAULT 0 /* 0 -> shift out / 1 -> don't shift out */
-@@ -28,4 +28,4 @@
-
- #define NATIVECODE euc /* EUC Kanji code */
-
--#define SKK_SERVER_HOST "ei5nazha" /* SKK server host */
-+#define SKK_SERVER_HOST "localhost" /* SKK server host */
---- a/configs/linux.h
-+++ b/configs/linux.h
-@@ -10,3 +10,12 @@
- #define NO_VFORK
-
- #define HAVE_SETREUID
-+#define HAVE_BSD_OPENPTY
-+
-+#include <stdlib.h>
-+#include <string.h>
-+#include <unistd.h>
-+
-+#if makefile_parameter
-+SYSLIBS=-lutil
-+#endif
---- a/protoMakefile
-+++ b/protoMakefile
-@@ -1,5 +1,5 @@
- CFLAGS=$(SYSINCLUDE) $(SYSDEFINE) $(DEFINE) $(OPTIMIZE)
--LIBS =$(SYSLIBS) $(EXTRALIBS) -ltermcap
-+LIBS =$(SYSLIBS) $(EXTRALIBS) $(LDFLAGS) -lncurses
-
- OBJS=fep.o connsh.o readwrite.o terms.o stty.o keybind.o romkan.o etc.o\
- kkconv.o keymap.o version.o
---- a/stty.c
-+++ b/stty.c
-@@ -306,7 +306,7 @@
- {
- int cpid;
- /* #ifdef _AIX */
--#if defined(_AIX) || defined(NECEWS) || defined(SOLARIS2)
-+#if defined(_AIX) || defined(NECEWS) || defined(SOLARIS2) || defined(LINUX)
- int statusp;
- reset_tty_without_close();
- cpid = wait(&statusp);
diff --git a/app-i18n/skkfep/files/skkfep-system-dic.patch b/app-i18n/skkfep/files/skkfep-system-dic.patch
deleted file mode 100644
index ba57a2a41f0b..000000000000
--- a/app-i18n/skkfep/files/skkfep-system-dic.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/kkconv.c
-+++ b/kkconv.c
-@@ -660,7 +660,9 @@
- flushOut(l);
- #ifdef USE_SERVER
- if (!CandFromServer) {
-- selectCand(FirstCandEntry,CurrentCand);
-+ if (FirstCandEntry != NULL) {
-+ selectCand(FirstCandEntry,CurrentCand);
-+ }
- }
- else if (NetLearnMode != LearnOff) {
- if (CurrentCand->dicitem == NULL) {