summaryrefslogtreecommitdiff
path: root/app-i18n/skkfep/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/skkfep/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/skkfep/files')
-rw-r--r--app-i18n/skkfep/files/skkfep-annotation.patch29
-rw-r--r--app-i18n/skkfep/files/skkfep-gentoo.patch75
-rw-r--r--app-i18n/skkfep/files/skkfep-system-dic.patch13
3 files changed, 117 insertions, 0 deletions
diff --git a/app-i18n/skkfep/files/skkfep-annotation.patch b/app-i18n/skkfep/files/skkfep-annotation.patch
new file mode 100644
index 000000000000..8145c2b069e0
--- /dev/null
+++ b/app-i18n/skkfep/files/skkfep-annotation.patch
@@ -0,0 +1,29 @@
+--- a/kkconv.c
++++ b/kkconv.c
+@@ -645,6 +645,7 @@
+ char c;
+ {
+ int l;
++ char *p;
+ DicList dlist;
+
+ kanjiSelectionEffect(0);
+@@ -653,7 +654,17 @@
+ if (OkuriInput)
+ l += strlen(OkuriBuf);
+ csrLeft(l);
+- writeShells(CurrentCand->candword);
++ p= strrchr(CurrentCand->candword,';');
++ if (p != NULL) {
++ erase(l);
++ csrLeft(l);
++ l -= strlen(p);
++ *p = '\0';
++ writeShells(CurrentCand->candword);
++ *p = ';';
++ } else {
++ writeShells(CurrentCand->candword);
++ }
+ if (OkuriInput) {
+ writeShells(OkuriBuf);
+ }
diff --git a/app-i18n/skkfep/files/skkfep-gentoo.patch b/app-i18n/skkfep/files/skkfep-gentoo.patch
new file mode 100644
index 000000000000..2afe3537361e
--- /dev/null
+++ b/app-i18n/skkfep/files/skkfep-gentoo.patch
@@ -0,0 +1,75 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,16 +2,16 @@
+ # Makefile for skkfep
+ #
+ all: genMakefile
+- make -f genMakefile all
++ $(MAKE) -f genMakefile all
+
+ skkfep: genMakefile
+- make -f genMakefile skkfep
++ $(MAKE) -f genMakefile skkfep
+
+ simpledic: genMakefile
+- make -f genMakefile simpledic
++ $(MAKE) -f genMakefile simpledic
+
+ clean: genMakefile
+- make -f genMakefile clean
++ $(MAKE) -f genMakefile clean
+ rm -f genMakefile
+
+ genMakefile: protoMakefile config.h
+--- a/config.h
++++ b/config.h
+@@ -14,7 +14,7 @@
+ #define DEFAULT_KANAKEY "^j"
+
+ /* By Y. Kaneko */
+-/*#define KUTOUTEN /* "."->maru, ","->ten */
++#define KUTOUTEN /* "."->maru, ","->ten */
+
+ #define KANJIBS /* do/don't shuft-out BS code in JIS mode */
+ #define KANJIBS_DEFAULT 0 /* 0 -> shift out / 1 -> don't shift out */
+@@ -28,4 +28,4 @@
+
+ #define NATIVECODE euc /* EUC Kanji code */
+
+-#define SKK_SERVER_HOST "ei5nazha" /* SKK server host */
++#define SKK_SERVER_HOST "localhost" /* SKK server host */
+--- a/configs/linux.h
++++ b/configs/linux.h
+@@ -10,3 +10,12 @@
+ #define NO_VFORK
+
+ #define HAVE_SETREUID
++#define HAVE_BSD_OPENPTY
++
++#include <stdlib.h>
++#include <string.h>
++#include <unistd.h>
++
++#if makefile_parameter
++SYSLIBS=-lutil
++#endif
+--- a/protoMakefile
++++ b/protoMakefile
+@@ -1,5 +1,5 @@
+ CFLAGS=$(SYSINCLUDE) $(SYSDEFINE) $(DEFINE) $(OPTIMIZE)
+-LIBS =$(SYSLIBS) $(EXTRALIBS) -ltermcap
++LIBS =$(SYSLIBS) $(EXTRALIBS) $(LDFLAGS) -lncurses
+
+ OBJS=fep.o connsh.o readwrite.o terms.o stty.o keybind.o romkan.o etc.o\
+ kkconv.o keymap.o version.o
+--- a/stty.c
++++ b/stty.c
+@@ -306,7 +306,7 @@
+ {
+ int cpid;
+ /* #ifdef _AIX */
+-#if defined(_AIX) || defined(NECEWS) || defined(SOLARIS2)
++#if defined(_AIX) || defined(NECEWS) || defined(SOLARIS2) || defined(LINUX)
+ int statusp;
+ reset_tty_without_close();
+ cpid = wait(&statusp);
diff --git a/app-i18n/skkfep/files/skkfep-system-dic.patch b/app-i18n/skkfep/files/skkfep-system-dic.patch
new file mode 100644
index 000000000000..ba57a2a41f0b
--- /dev/null
+++ b/app-i18n/skkfep/files/skkfep-system-dic.patch
@@ -0,0 +1,13 @@
+--- a/kkconv.c
++++ b/kkconv.c
+@@ -660,7 +660,9 @@
+ flushOut(l);
+ #ifdef USE_SERVER
+ if (!CandFromServer) {
+- selectCand(FirstCandEntry,CurrentCand);
++ if (FirstCandEntry != NULL) {
++ selectCand(FirstCandEntry,CurrentCand);
++ }
+ }
+ else if (NetLearnMode != LearnOff) {
+ if (CurrentCand->dicitem == NULL) {