summaryrefslogtreecommitdiff
path: root/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild')
-rw-r--r--app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild b/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..ad0fc7d82d8a
--- /dev/null
+++ b/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="An input module for Smart Common Input Method (SCIM) which uses uim as backend"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/uim-1.5.0
+ >=app-i18n/scim-1.4.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc43.patch" \
+ "${FILESDIR}/${P}-uim-1.5.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog README THANKS || die
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog
+}