summaryrefslogtreecommitdiff
path: root/app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild')
-rw-r--r--app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild b/app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild
new file mode 100644
index 000000000000..c881bd636a93
--- /dev/null
+++ b/app-i18n/scim-pinyin/scim-pinyin-0.5.92.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Smart Common Input Method (SCIM) Smart Pinyin Input Method"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/libXt
+ || ( >=app-i18n/scim-1.1 >=app-i18n/scim-cvs-1.1 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+AUTOTOOLS_AUTORECONF=1
+PATCHES=(
+ "${FILESDIR}/${PN}-0.5.91-fixconfigure.patch"
+)
+DOCS=( AUTHORS NEWS README ChangeLog )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ --disable-skim-support
+ --without-arts
+ --disable-static
+ --disable-depedency-tracking
+ )
+ autotools-utils_src_configure
+}