summaryrefslogtreecommitdiff
path: root/app-i18n/nabi/nabi-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/nabi/nabi-1.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/nabi/nabi-1.0.0.ebuild')
-rw-r--r--app-i18n/nabi/nabi-1.0.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-i18n/nabi/nabi-1.0.0.ebuild b/app-i18n/nabi/nabi-1.0.0.ebuild
new file mode 100644
index 000000000000..b9c453f52723
--- /dev/null
+++ b/app-i18n/nabi/nabi-1.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Simple Hanguk X Input Method"
+HOMEPAGE="https://github.com/choehwanjin/nabi"
+SRC_URI="https://github.com/choehwanjin/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug nls"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=app-i18n/libhangul-0.1.0
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.4:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/pango
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS ChangeLog.0 NEWS README TODO )
+
+S="${WORKDIR}"/${PN}-${P}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ # Broken configure: --disable-debug also enables debug
+ use debug && \
+ myconf="${myconf} --enable-debug"
+
+ econf ${myconf}
+}
+
+src_install() {
+ default
+
+ insinto /etc/X11/xinit/xinput.d
+ sed -e "s:@EPREFIX@:${EPREFIX}:g" "${FILESDIR}/xinput-${PN}" | newins - "${PN}.conf"
+}
+
+pkg_postinst() {
+ elog "You MUST add environment variable..."
+ elog
+ elog "export XMODIFIERS=\"@im=nabi\""
+ elog
+}