summaryrefslogtreecommitdiff
path: root/app-i18n/kcc/kcc-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /app-i18n/kcc/kcc-1.0.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'app-i18n/kcc/kcc-1.0.ebuild')
-rw-r--r--app-i18n/kcc/kcc-1.0.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/app-i18n/kcc/kcc-1.0.ebuild b/app-i18n/kcc/kcc-1.0.ebuild
index bcb220713949..20ee1ee57350 100644
--- a/app-i18n/kcc/kcc-1.0.ebuild
+++ b/app-i18n/kcc/kcc-1.0.ebuild
@@ -1,34 +1,33 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A Kanji code converter"
HOMEPAGE="http://www2s.biglobe.ne.jp/~Nori/ruby/"
-SRC_URI="ftp://ftp.jp.freebsd.org/pub/FreeBSD/ports/distfiles/${PN}.tar.gz"
+SRC_URI="mirror://gentoo/${PN}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE=""
S="${WORKDIR}/${PN}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-gcc3-gentoo.diff"
- epatch "${FILESDIR}/${PN}-exit.diff"
- sed -i "s:\(-o kcc\):\$(LDFLAGS) \1:" Makefile
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc3-gentoo.diff
+ "${FILESDIR}"/${PN}-exit.diff
+ "${FILESDIR}"/${PN}-1.0-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CC
}
src_install() {
dobin kcc
- dodoc README
+ einstalldocs
+
cp -f kcc.jman kcc.1 || die
doman -i18n=ja kcc.1
}