summaryrefslogtreecommitdiff
path: root/app-i18n/kanjipad/kanjipad-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/kanjipad/kanjipad-2.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/kanjipad/kanjipad-2.0.0.ebuild')
-rw-r--r--app-i18n/kanjipad/kanjipad-2.0.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-i18n/kanjipad/kanjipad-2.0.0.ebuild b/app-i18n/kanjipad/kanjipad-2.0.0.ebuild
new file mode 100644
index 000000000000..82d47a93e351
--- /dev/null
+++ b/app-i18n/kanjipad/kanjipad-2.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Japanese handwriting recognition tool"
+HOMEPAGE="https://fishsoup.net/software/kanjipad/"
+SRC_URI="https://fishsoup.net/software/kanjipad/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog README TODO jstroke/README-kanjipad )
+
+PATCHES=(
+ "${FILESDIR}/${P}-cflags.patch"
+ "${FILESDIR}/${P}-underlinking.patch"
+)
+
+src_prepare() {
+ default
+ perl -i -pe "s|PREFIX=/usr/local|PREFIX=/usr|;
+ s|-DG.*DISABLE_DEPRECATED||g" Makefile || die "Fixing Makefile failed"
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin kanjipad kpengine
+ insinto /usr/share/kanjipad
+ doins jdata.dat
+ einstalldocs
+}