summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-table/ibus-table-1.17.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 05:49:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 05:49:50 +0100
commit1ac83daac7198a5717483e1cfab669ba4f12debe (patch)
treefb9c448591e3f43e411800a609df633313aab78f /app-i18n/ibus-table/ibus-table-1.17.0.ebuild
parentfddb33ccaadabe03f5571606f796b45965b38e9c (diff)
gentoo auto-resync : 16:04:2023 - 05:49:50
Diffstat (limited to 'app-i18n/ibus-table/ibus-table-1.17.0.ebuild')
-rw-r--r--app-i18n/ibus-table/ibus-table-1.17.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/ibus-table-1.17.0.ebuild b/app-i18n/ibus-table/ibus-table-1.17.0.ebuild
new file mode 100644
index 000000000000..fa1d06003138
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.17.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}