summaryrefslogtreecommitdiff
path: root/app-i18n/freewnn/freewnn-1.1.1_alpha22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/freewnn/freewnn-1.1.1_alpha22.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/freewnn/freewnn-1.1.1_alpha22.ebuild')
-rw-r--r--app-i18n/freewnn/freewnn-1.1.1_alpha22.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-i18n/freewnn/freewnn-1.1.1_alpha22.ebuild b/app-i18n/freewnn/freewnn-1.1.1_alpha22.ebuild
new file mode 100644
index 000000000000..f4d5668b35ee
--- /dev/null
+++ b/app-i18n/freewnn/freewnn-1.1.1_alpha22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_P="FreeWnn-${PV/_alpha/-a0}"
+
+DESCRIPTION="Network-Extensible Kana-to-Kanji Conversion System"
+HOMEPAGE="http://freewnn.sourceforge.jp/ http://www.freewnn.org/"
+SRC_URI="mirror://sourceforge.jp/${PN}/59257/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="ipv6"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-parallel-build.patch
+ "${FILESDIR}"/${PN}-Wformat-security.patch
+)
+DOCS="ChangeLog* CONTRIBUTORS"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s/WNNOWNER = wnn/WNNOWNER = root/" \
+ -e "s/@INSTPGMFLAGS@//" \
+ makerule.mk.in
+
+ # bug #542534
+ sed -i \
+ -e "s/egrep -v/egrep -av/" \
+ PubdicPlus/Makefile.in \
+ Wnn/pubdicplus/Makefile.in \
+ cWnn/[ct]dic/Makefile.in \
+ kWnn/kdic/Makefile.in
+}
+
+src_configure() {
+ econf \
+ $(use_with ipv6) \
+ --disable-cWnn \
+ --disable-kWnn
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man
+ einstalldocs
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}