summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx/fcitx-4.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /app-i18n/fcitx/fcitx-4.9999.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'app-i18n/fcitx/fcitx-4.9999.ebuild')
-rw-r--r--app-i18n/fcitx/fcitx-4.9999.ebuild21
1 files changed, 17 insertions, 4 deletions
diff --git a/app-i18n/fcitx/fcitx-4.9999.ebuild b/app-i18n/fcitx/fcitx-4.9999.ebuild
index 295d5fa08862..76f6bdd6c634 100644
--- a/app-i18n/fcitx/fcitx-4.9999.ebuild
+++ b/app-i18n/fcitx/fcitx-4.9999.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+LUA_COMPAT=(lua{5-1,5-2,5-3,5-4})
-inherit cmake gnome2-utils xdg-utils
+inherit cmake gnome2-utils lua-single xdg-utils
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
inherit git-r3
@@ -28,7 +29,9 @@ LICENSE="BSD-1 GPL-2+ LGPL-2+ MIT"
SLOT="4"
KEYWORDS=""
IUSE="+X +autostart +cairo debug +enchant gtk2 +gtk3 +introspection lua nls opencc +pango +table test +xkb"
-REQUIRED_USE="cairo? ( X ) pango? ( cairo )"
+REQUIRED_USE="cairo? ( X )
+ lua? ( ${LUA_REQUIRED_USE} )
+ pango? ( cairo )"
RESTRICT="!test? ( test )"
BDEPEND="dev-util/glib-utils
@@ -62,7 +65,7 @@ DEPEND="dev-libs/glib:2
enchant? ( app-text/enchant:= )
gtk2? ( x11-libs/gtk+:2 )
gtk3? ( x11-libs/gtk+:3 )
- lua? ( dev-lang/lua:= )
+ lua? ( ${LUA_DEPS} )
nls? ( sys-devel/gettext )
opencc? ( app-i18n/opencc:0= )
xkb? (
@@ -72,12 +75,17 @@ DEPEND="dev-libs/glib:2
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}/${PN}-4.2.9.8-enchant.patch"
"${FILESDIR}/${PN}-4.2.9.8-xkb.patch"
)
DOCS=(AUTHORS ChangeLog THANKS)
+pkg_setup() {
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
src_prepare() {
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
ln -s "${DISTDIR}/fcitx-data-pinyin.tar.gz" src/im/pinyin/data/pinyin.tar.gz || die
@@ -114,6 +122,11 @@ src_configure() {
-DENABLE_XDGAUTOSTART=$(usex autostart ON OFF)
-DENABLE_XKB=$(usex xkb ON OFF)
)
+ if use lua; then
+ mycmakeargs+=(
+ -DLUA_MODULE_NAME=lua
+ )
+ fi
cmake_src_configure
}