summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild')
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild b/app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild
new file mode 100644
index 000000000000..9b139edf92ed
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-0.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Rime support for Fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="https://fcitx.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.7
+ app-i18n/librime
+ app-i18n/rime-data
+ x11-libs/libnotify"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # dont build data resource here, already provided by app-i18n/rime-data
+ sed -i -e 's|add_subdirectory(data)||' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRIME_DATA_DIR=/usr/share/rime-data
+ )
+ cmake-utils_src_configure
+}