summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-qt5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-qt5
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-qt5')
-rw-r--r--app-i18n/fcitx-qt5/Manifest4
-rw-r--r--app-i18n/fcitx-qt5/fcitx-qt5-1.2.3.ebuild40
-rw-r--r--app-i18n/fcitx-qt5/fcitx-qt5-4.9999.ebuild40
-rw-r--r--app-i18n/fcitx-qt5/metadata.xml15
4 files changed, 99 insertions, 0 deletions
diff --git a/app-i18n/fcitx-qt5/Manifest b/app-i18n/fcitx-qt5/Manifest
new file mode 100644
index 000000000000..e1c93ba5aaec
--- /dev/null
+++ b/app-i18n/fcitx-qt5/Manifest
@@ -0,0 +1,4 @@
+DIST fcitx-qt5-1.2.3.tar.xz 134124 BLAKE2B 0c17f9c3b9d9878fe228881c7287375d3b73a8c27f806590747e56b8644a86300e243d62efcb6589d197edd352e2a79d49be704718ff53381e2fb5e2a5a2b1af SHA512 e3e9a76419caca4eeebf3c149a72ee939a25f463d03dd8461caf44cace310278b08e83d460112f240cd54ed05dba3c5e9732198f0c3d0b9d81c3a444c33ab8d3
+EBUILD fcitx-qt5-1.2.3.ebuild 877 BLAKE2B c2fd8acc1d788ea4cffc7f933e7aace5086b7e2872fe7000b3cf68ca06fabc6340bb1fc6492fd62c44d61eff94273c499b25ce8c94e54813e08ba54726f5551d SHA512 afc8f658a894acb45e13a4fbe2bc3ff204f13465b90b471fccf37d7c039aed8c8f5a0a7709fabff1e81745befeb98cbdb659207e261b2ebb9f83b640d6771970
+EBUILD fcitx-qt5-4.9999.ebuild 852 BLAKE2B 1ad3ebf0ac906e6db6ff3c3d6c230da37cffa459101596e4358133737e0def3579e7479098cdf4157e7f65a4bdaa511907532a65b026c357c9dc857cfc7d6eb5 SHA512 15bab1b40244a70f18b331a78c8385d8294b46b0275f5436a6a2f29eb55427ca647320da491454c6a4dc06c9c0b333608e3fd2b54aefd3734cfe96278b41f057
+MISC metadata.xml 448 BLAKE2B 1750c8c3d071bf62c166cfcf686e9a37d80e807842a274523454dc88da1dd71f882dcc5d43383966c0389f1cdc0f4c7b355566d0bd9e7272a69a01251e690b12 SHA512 329b0f97ef19e470317fae5493ece05d39e49b4d1c84736cc644c3f22d667157251d7bd176989e0e0968db9e8e36fb388451ba6186a639fc439adc45084bf222
diff --git a/app-i18n/fcitx-qt5/fcitx-qt5-1.2.3.ebuild b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.3.ebuild
new file mode 100644
index 000000000000..2c54b501abd1
--- /dev/null
+++ b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-qt5.git"
+fi
+
+DESCRIPTION="Fcitx input method module for Qt 5"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-qt5"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="BSD GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS="amd64 ~hppa ppc ppc64 x86"
+IUSE=""
+
+# Private headers of dev-qt/qtgui:5 used.
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ virtual/libintl
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ kde-frameworks/extra-cmake-modules:5
+ virtual/pkgconfig"
+
+DOCS=()
diff --git a/app-i18n/fcitx-qt5/fcitx-qt5-4.9999.ebuild b/app-i18n/fcitx-qt5/fcitx-qt5-4.9999.ebuild
new file mode 100644
index 000000000000..3d87cd55c432
--- /dev/null
+++ b/app-i18n/fcitx-qt5/fcitx-qt5-4.9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-qt5.git"
+fi
+
+DESCRIPTION="Fcitx input method module for Qt 5"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-qt5"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="BSD GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+# Private headers of dev-qt/qtgui:5 used.
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ virtual/libintl
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ kde-frameworks/extra-cmake-modules:5
+ virtual/pkgconfig"
+
+DOCS=()
diff --git a/app-i18n/fcitx-qt5/metadata.xml b/app-i18n/fcitx-qt5/metadata.xml
new file mode 100644
index 000000000000..8410356fbf60
--- /dev/null
+++ b/app-i18n/fcitx-qt5/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">fcitx/fcitx-qt5</remote-id>
+ </upstream>
+</pkgmetadata>