summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-hangul/fcitx-hangul-5.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-14 01:14:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-14 01:14:50 +0000
commit94eb99943eafb48140b436b347abaaee77209c01 (patch)
treebb4f0519a6c0880b24c88b1666976a36a464a8df /app-i18n/fcitx-hangul/fcitx-hangul-5.1.1.ebuild
parenta7ec94f7d22ee22df2e424c1d3f842510b7993aa (diff)
gentoo auto-resync : 14:01:2024 - 01:14:49
Diffstat (limited to 'app-i18n/fcitx-hangul/fcitx-hangul-5.1.1.ebuild')
-rw-r--r--app-i18n/fcitx-hangul/fcitx-hangul-5.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-i18n/fcitx-hangul/fcitx-hangul-5.1.1.ebuild b/app-i18n/fcitx-hangul/fcitx-hangul-5.1.1.ebuild
new file mode 100644
index 000000000000..bb89c3061af9
--- /dev/null
+++ b/app-i18n/fcitx-hangul/fcitx-hangul-5.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-hangul"
+
+inherit cmake xdg
+
+DESCRIPTION="Korean Hangul input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-hangul"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=app-i18n/fcitx-5.1.6:5
+ >=app-i18n/libhangul-0.0.12
+ virtual/libiconv
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+DOCS=( AUTHORS )