summaryrefslogtreecommitdiff
path: root/app-i18n/fbterm/fbterm-1.7-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fbterm/fbterm-1.7-r5.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fbterm/fbterm-1.7-r5.ebuild')
-rw-r--r--app-i18n/fbterm/fbterm-1.7-r5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-i18n/fbterm/fbterm-1.7-r5.ebuild b/app-i18n/fbterm/fbterm-1.7-r5.ebuild
new file mode 100644
index 000000000000..45117addebe2
--- /dev/null
+++ b/app-i18n/fbterm/fbterm-1.7-r5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools fcaps
+
+DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
+HOMEPAGE="https://code.google.com/p/fbterm"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.0.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpm video_cards_vesa"
+
+RDEPEND="media-libs/fontconfig
+ media-libs/freetype:2
+ gpm? ( sys-libs/gpm )
+ video_cards_vesa? ( dev-libs/libx86 )
+ >=sys-libs/ncurses-6.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-gcc6.patch )
+
+FILECAPS=(
+ cap_sys_tty_config+ep usr/bin/${PN}
+)
+
+src_prepare() {
+ # bug #648472
+ sed -i "s/terminfo//" Makefile.am
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gpm) \
+ $(use_enable video_cards_vesa vesa)
+}
+
+src_install() {
+ default
+
+ use filecaps || fperms u+s /usr/bin/${PN}
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ elog "${PN} won't work with vga16fb. You have to use other native"
+ elog "framebuffer drivers or vesa driver."
+ elog "See ${EPREFIX}/usr/share/doc/${P}/README for details."
+ elog
+ elog "To use ${PN}, ensure you are in video group."
+}