summaryrefslogtreecommitdiff
path: root/app-forensics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-04 04:53:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-04 04:53:47 +0000
commitd074d0ba59e3121dba0c27c4a18f1e481f67b62a (patch)
treeacee0c96401da7cf239aa11858cb707d4e5ce930 /app-forensics
parenta8594a52da11d6e6e42aec90d9658f5fda35a77c (diff)
gentoo auto-resync : 04:12:2023 - 04:53:47
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/Manifest.gzbin4708 -> 4713 bytes
-rw-r--r--app-forensics/aflplusplus/Manifest2
-rw-r--r--app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild (renamed from app-forensics/aflplusplus/aflplusplus-4.08c.ebuild)19
3 files changed, 14 insertions, 7 deletions
diff --git a/app-forensics/Manifest.gz b/app-forensics/Manifest.gz
index a49242bd40f9..969296dd2ec5 100644
--- a/app-forensics/Manifest.gz
+++ b/app-forensics/Manifest.gz
Binary files differ
diff --git a/app-forensics/aflplusplus/Manifest b/app-forensics/aflplusplus/Manifest
index e3fd3c89ef30..11253b0ab19f 100644
--- a/app-forensics/aflplusplus/Manifest
+++ b/app-forensics/aflplusplus/Manifest
@@ -2,5 +2,5 @@ DIST aflplusplus-4.07c-patches.tar.xz 4788 BLAKE2B de109198fbabfce2554459fee6a14
DIST aflplusplus-4.07c.tar.gz 2878659 BLAKE2B c3c4c5507e29ed8015784378a13a55cb6b389dec915979749b1869496c16366ce876f1eecc91eb09d51cc58266a92296218cd5eda2a201f5cf4faaa2ea61942f SHA512 c62fce112d59ef5ffb847adab9a7ff8486d44e6316a391392979da19a8160b55f9af7f75fd39cdc98997b3e166f4f6a33ddf31b827c9414a1392657701ecb5e8
DIST aflplusplus-4.08c.tar.gz 2894794 BLAKE2B 5576ec54969c7ae10b05fe10320581b348f989c1bc412bd63b2ca7ecb3bd1782a90c2660d971375667f6dd820f9035d7abb2207f59a1aaa5e7640d352eaa5757 SHA512 52c35ed544db8be778b79a64977fcc74092b541c4c07a788b20f4b9e8db95ff9c52c997ebf6f5a1056f962f3551df06a5eca02679bc2b71bb9d8944c1f77984a
EBUILD aflplusplus-4.07c-r1.ebuild 2106 BLAKE2B bfe3abd284e563ddd73087142eecf7135df94e4f9f3dad76a77a878218c1ab863edf9c4df57434bb9e52c7be6a2bb2aed46a4539783a62d311bc7285ab5bb9f2 SHA512 1655959fce37bd04834544472c8248c6a4f3b1556c9622dbceefbecff5de972d91c38c616e5f510b7ef2a264f17cd532dc963b78e40cff20a0308a8447cc3f08
-EBUILD aflplusplus-4.08c.ebuild 2107 BLAKE2B fe74b13d735ad588ccad8938850229d3751183c6b14276e2d4ba85a1ac14c4dbe354818d49fdfdc44627fca9688b5173e84dd3681be2439d516f0477c4280bbf SHA512 78535d2cd55af1ddf7d81688b1d965a81a342dad50138d55c7e7b348b7b5f74077ac68e50e6c14b2e7da640b5b7a6b7b8051841b2d08071286ba042f896d9c02
+EBUILD aflplusplus-4.08c-r1.ebuild 2258 BLAKE2B 694a1e633970f905b3fba4f99b3d0b1758d10cd1c7bfdb3d33403c2bd13b9c7eea295622c3076c5397b9b80a1d3fa9cee2cbdd74880fe72ecdbd03586ba7872e SHA512 462f3d89db467b8813d32a81da4d1fe6d5ee44a3a6a3db9fa67051d0a64bf0e30398dba1f514c0284fa0ec5019979f4f3e4930001474d933d8522324c60672c1
MISC metadata.xml 328 BLAKE2B c9ad582740e9c2ad03a30fe0eaafb8ee19f0d9bc2e98cc7bcd14385a3407f84301479d324b92d3aecafdc1e5cfef1d2cfc8a15c2ecb5d8f2fa348d82de920128 SHA512 e56ce158f6764926c2ed4dc486f017ce75fa272ac8e6ad16e4a816f8c734d7313e3dc9cb007bab07efe73e59cab185312a02d6178296bfe25002719ce4975d14
diff --git a/app-forensics/aflplusplus/aflplusplus-4.08c.ebuild b/app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild
index 51cd62ea7a29..2451f727113e 100644
--- a/app-forensics/aflplusplus/aflplusplus-4.08c.ebuild
+++ b/app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild
@@ -5,6 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
LLVM_MAX_SLOT=17
+LLVM_MIN_SLOT=14
inherit toolchain-funcs llvm optfeature python-single-r1
AFL_PATCHSET="${PN}-4.07c-patches"
@@ -24,14 +25,20 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# This isn't compatible with sandbox
RESTRICT="test"
-RDEPEND="
- ${PYTHON_DEPS}
+LLVM_DEPS="
<sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):=
|| (
- sys-devel/clang:14
- sys-devel/clang:15
- sys-devel/clang:${LLVM_MAX_SLOT}
- )
+"
+# We go downwards as Portage prefers left-most in || ( .. )
+for ((i=${LLVM_MAX_SLOT}; i >= ${LLVM_MIN_SLOT}; i--)) ; do
+ LLVM_DEPS+=" sys-devel/clang:${i}"
+done
+LLVM_DEPS+=" )"
+unset i
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${LLVM_DEPS}
!app-forensics/afl
"
DEPEND="