summaryrefslogtreecommitdiff
path: root/app-forensics/galleta/galleta-20040505_p1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-forensics/galleta/galleta-20040505_p1.ebuild
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-forensics/galleta/galleta-20040505_p1.ebuild')
-rw-r--r--app-forensics/galleta/galleta-20040505_p1.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/app-forensics/galleta/galleta-20040505_p1.ebuild b/app-forensics/galleta/galleta-20040505_p1.ebuild
index 890ad5ab0d30..9192b6bdb8cb 100644
--- a/app-forensics/galleta/galleta-20040505_p1.ebuild
+++ b/app-forensics/galleta/galleta-20040505_p1.ebuild
@@ -1,25 +1,32 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
MY_P=${PN}_${PV/_p/_}
+
DESCRIPTION="IE Cookie Parser"
HOMEPAGE="https://sourceforge.net/projects/odessa/"
SRC_URI="mirror://sourceforge/odessa/${MY_P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-S=${WORKDIR}/${MY_P}
+S=${WORKDIR}/${MY_P}/src
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
-src_compile() {
- cd src
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o galleta galleta.c -lm -lc || die "failed to compile"
+src_configure() {
+ tc-export CC
}
src_install() {
- dodoc Readme.txt
- dobin src/galleta
+ dobin ${PN}
+ dodoc ../{CHANGES,Readme.txt}
}