summaryrefslogtreecommitdiff
path: root/app-forensics/afflib/afflib-3.7.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
commita3bb28551df94028000fb72308a9e9baa01458b0 (patch)
tree33b14c7bf0dffbd5bb04dbd5b395514ebdda4896 /app-forensics/afflib/afflib-3.7.20.ebuild
parent6657c680376cedf378fcf328e5fa03ed3b41d580 (diff)
gentoo auto-resync : 03:06:2024 - 00:07:25
Diffstat (limited to 'app-forensics/afflib/afflib-3.7.20.ebuild')
-rw-r--r--app-forensics/afflib/afflib-3.7.20.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/app-forensics/afflib/afflib-3.7.20.ebuild b/app-forensics/afflib/afflib-3.7.20.ebuild
deleted file mode 100644
index a8d20b77ec2b..000000000000
--- a/app-forensics/afflib/afflib-3.7.20.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit autotools python-single-r1
-
-MY_PN=AFFLIBv3
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Library that implements the AFF image standard"
-HOMEPAGE="https://github.com/sshock/AFFLIBv3/"
-SRC_URI="https://github.com/sshock/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ppc x86 ~x64-macos"
-IUSE="fuse ncurses python qemu readline s3 static-libs threads"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-# Tests don't play well with sandbox
-RESTRICT="test"
-
-RDEPEND="
- dev-libs/expat
- sys-libs/zlib:=
- fuse? ( sys-fs/fuse:0 )
- dev-libs/openssl:=
- ncurses? ( sys-libs/ncurses:= )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]')
- )
- readline? ( sys-libs/readline:= )
- s3? ( net-misc/curl )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.7.19-search-path.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e '/FLAGS/s: -g::' \
- -e 's:-D_FORTIFY_SOURCE=2::' \
- configure.ac || die
-
- eautoreconf
-}
-
-src_configure() {
- # Hacks for automagic dependencies
- use ncurses || export ac_cv_lib_ncurses_initscr=no
- use readline || export ac_cv_lib_readline_readline=no
-
- local myeconfargs=(
- $(use_enable fuse)
- $(use_enable python)
- $(use_enable qemu)
- $(use_enable s3)
- $(use_enable static-libs static)
- $(use_enable threads threading)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- find "${ED}" -name "*.la" -delete || die
-}