summaryrefslogtreecommitdiff
path: root/app-eselect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-18 18:50:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-18 18:50:06 +0000
commitbc7e0dbdbd194a8c2e09f82e1a5a4ea5e1b556f4 (patch)
treecb9186c88b5cfbd6c51e4b283677075c5c6ea38e /app-eselect
parentebb07c94f800907e02d2a6b92c1bc757b2f86f49 (diff)
gentoo auto-resync : 18:03:2024 - 18:50:06
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/Manifest.gzbin6712 -> 6718 bytes
-rw-r--r--app-eselect/eselect-pinentry/Manifest2
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild19
-rw-r--r--app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.420
4 files changed, 41 insertions, 0 deletions
diff --git a/app-eselect/Manifest.gz b/app-eselect/Manifest.gz
index b55b4d18b12c..830a8608a5b7 100644
--- a/app-eselect/Manifest.gz
+++ b/app-eselect/Manifest.gz
Binary files differ
diff --git a/app-eselect/eselect-pinentry/Manifest b/app-eselect/eselect-pinentry/Manifest
index cdcbcf45f002..9640ad05530b 100644
--- a/app-eselect/eselect-pinentry/Manifest
+++ b/app-eselect/eselect-pinentry/Manifest
@@ -1,3 +1,5 @@
AUX pinentry.eselect-0.7.3 420 BLAKE2B e35c743800a991848927a395ef547baeb88a234740e4d9fc3ab21415a5bee722dbde6a67a84ee706f35595778f1bbc827460bb0e1b02011bab0d0b51d8f756cc SHA512 1ffe320c3398f10a50b2478e6e2fc1ca5aa7b989221f4a2b5a583b28aa0872b8e02356b0fa5e03ce0f1d79b98d7994fbae999c420194ffd8203662247daa95f7
+AUX pinentry.eselect-0.7.4 434 BLAKE2B 0ce9dabf5ac8618069591f220591c73fabbaf31e4231f2fdd9349acc19251d82b2019623ab8353a5a550317a54b0d30eaa45179d413b2af5442455aceaeaaf87 SHA512 de2388ca79a5ec77aa184d085bea4a8bdde6a5040b9d3c2ecabe09481d6512d3f9d027105060897cf9442fd6b41bbf81ff9f432708add237b065462e4d1aced7
EBUILD eselect-pinentry-0.7.3.ebuild 598 BLAKE2B 7fc9592defcf109feb5ef60939bb5c9c88e81bfee7987ee92c5d797d2e2b79ba681f54e03e9fc3057ab4e054dc8842eada20a0e2c2ea363c4da98ee59134d5cf SHA512 9d3d8965ec97af642f6f2dcbf64c5b200acd5e2c40b01263c546fcaf7fecfd36de2fcaed9e6e590edb788cb56b5727ee2a13672a8fd94ae23d92a0d06abf94cd
+EBUILD eselect-pinentry-0.7.4.ebuild 606 BLAKE2B ce298acd1a2f4c84c5c82a8033ede4c98164516b3fe9af1460bc40d66f2823e95a5e86ac9dc7c1adaddf55a6dbc01b9e73e2ac5122afed583c9a4dd67783d2e7 SHA512 98da9c63f544f23b2fe613c9af3dfee9537dfc858c5d291e64ea0654ca3c7e7fe65786144faba377fa692693ec6bf629ff155ebc54446d61b8200d492f4b14a3
MISC metadata.xml 192 BLAKE2B fef49cb9e1dda8063c379e650d4897670410d2c0641f469b8a200d5e7ec8d3f505e692277d03b583790cb1340ece9c2e8f7e7c9ff5080d42a2e0ef3fc7138a44 SHA512 bece454b8da734c7a28ce25f8080b3fca56332e57cde854c50f0b884ba3836f1af7782a1ee9f63e6aeff4830e2bca71c5c466471fc82eee75339565aab6495d5
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild
new file mode 100644
index 000000000000..2f34f9567def
--- /dev/null
+++ b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Manage /usr/bin/pinentry symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/pinentry.eselect-${PV} pinentry.eselect
+}
diff --git a/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.4 b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.4
new file mode 100644
index 000000000000..74c6f14d8b53
--- /dev/null
+++ b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.4
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage /usr/bin/pinentry implementation"
+MAINTAINER="maintainer-needed@gentoo.org"
+VERSION="0.7.4"
+
+SYMLINK_PATH=/usr/bin/pinentry
+SYMLINK_TARGETS=(
+ pinentry-efl
+ pinentry-gnome3
+ pinentry-qt5
+ pinentry-qt6
+ pinentry-curses
+ pinentry-tty
+ pinentry-emacs
+)
+SYMLINK_DESCRIPTION='pinentry binary'
+
+inherit bin-symlink