summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-eselect/eselect-python
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-eselect/eselect-python')
-rw-r--r--app-eselect/eselect-python/Manifest6
-rw-r--r--app-eselect/eselect-python/eselect-python-20160516.ebuild39
-rw-r--r--app-eselect/eselect-python/eselect-python-20171204.ebuild40
-rw-r--r--app-eselect/eselect-python/eselect-python-99999999.ebuild40
-rw-r--r--app-eselect/eselect-python/metadata.xml8
5 files changed, 133 insertions, 0 deletions
diff --git a/app-eselect/eselect-python/Manifest b/app-eselect/eselect-python/Manifest
new file mode 100644
index 000000000000..95e7f13c0cb9
--- /dev/null
+++ b/app-eselect/eselect-python/Manifest
@@ -0,0 +1,6 @@
+DIST eselect-python-20160516.tar.bz2 46549 BLAKE2B f8703ed35d9607a940fca1bb1d9612de62a04dd1fb065fa31db7438ee08b766b5ef84a4ef10f3f58654acb7fda4bc5e32abceccd0ecec632b364e4a55834ba2d SHA512 0ac310e13bca9e3cdfdd55820cc2956cacf28ade99c1b5048edadd48c6a04c2ae1037207aaac74fcd75e809cf993f88b52e463979b68bd123fe925e491a7030a
+DIST eselect-python-20171204.tar.bz2 46655 BLAKE2B f0bc46c796a1b9e01f964994219b9c7831f99844a12e97429b40482e28a590a2d825f7b6fbca27b0ca1ce616e5cfb388272af686ea2de65fda69da0319fddeda SHA512 f89183ca992bc38f2308a3217602d5ce6ec4b3b5b614f2aec48fb5b3b7e50a2e44dd18af36a7cfbd4b45d05346f2be97605e35fd274558e9173c6974681c8fa9
+EBUILD eselect-python-20160516.ebuild 1089 BLAKE2B f530b036157ee01b3950033151d752b6544881c785b95e75a5a653bb6f7568e185d39aa5b8c2e00eab650e93e9b6184b4d2ec5bf90ac09417f452932caf2a119 SHA512 24ae15fd8f95adecb4d7b09a3008dda42507df30484ca60988117c364f3f3c2eafee23e5b56660960cb7c4eee09672b4fe3ca7a8d49e42e2398f68bcffad0502
+EBUILD eselect-python-20171204.ebuild 1097 BLAKE2B aba4e4bdf7a42648e0de794efb149cd1009d1eb04f3425ebfea426096e905f13fec3fcf58c2d4ae077db345caa359567fca4921f919aded50bae2e3a58192729 SHA512 bd0330ef77f0b1b6ccb76734fb58cc43a96ac490e08e4871b21e1425c67ec2c7ac5a06f08a21ad5c21f3970ddc91940766dedd3047d2e1f17583df25bcfcec6b
+EBUILD eselect-python-99999999.ebuild 1111 BLAKE2B 32d94580e545a8853b66bf9c30977c52c45adfb98e1de9f0aed108bbd088f8f6de1a7367285161b26d88125ab2dc8bd74f985f4677b2d6abf64ab42da9f5b55a SHA512 33d648c0e8f7ecfeb3e5f5d9838887a64bcb2aea9b3c40381d5306c72cd71c823cb55f9baf1129bb80c0cc7f9ff5223d6799aad9d863a974d484baa9960658a7
+MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/app-eselect/eselect-python/eselect-python-20160516.ebuild b/app-eselect/eselect-python/eselect-python-20160516.ebuild
new file mode 100644
index 000000000000..7d3e622fb11b
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20160516.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# python-exec-2.4.2 for working -l option
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2"
+
+src_prepare() {
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/eselect-python-20171204.ebuild b/app-eselect/eselect-python/eselect-python-20171204.ebuild
new file mode 100644
index 000000000000..a53d884a70dc
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20171204.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# python-exec-2.4.2 for working -l option
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2"
+
+src_prepare() {
+ default
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/eselect-python-99999999.ebuild b/app-eselect/eselect-python/eselect-python-99999999.ebuild
new file mode 100644
index 000000000000..bcf52199d557
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-99999999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# python-exec-2.4.2 for working -l option
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2"
+
+src_prepare() {
+ default
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/metadata.xml b/app-eselect/eselect-python/metadata.xml
new file mode 100644
index 000000000000..7f4f33c6dbc9
--- /dev/null
+++ b/app-eselect/eselect-python/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>