summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-eselect/eselect-python
reinit the tree, so we can have metadata
Diffstat (limited to 'app-eselect/eselect-python')
-rw-r--r--app-eselect/eselect-python/Manifest6
-rw-r--r--app-eselect/eselect-python/eselect-python-20160516.ebuild39
-rw-r--r--app-eselect/eselect-python/eselect-python-99999999.ebuild39
-rw-r--r--app-eselect/eselect-python/metadata.xml8
4 files changed, 92 insertions, 0 deletions
diff --git a/app-eselect/eselect-python/Manifest b/app-eselect/eselect-python/Manifest
new file mode 100644
index 000000000000..a2eb0079498b
--- /dev/null
+++ b/app-eselect/eselect-python/Manifest
@@ -0,0 +1,6 @@
+DIST eselect-python-20160516.tar.bz2 46549 SHA256 bea0a39d9e5afb7513be47955a82efa636b983de6388965df517cb1eb7615fd2 SHA512 0ac310e13bca9e3cdfdd55820cc2956cacf28ade99c1b5048edadd48c6a04c2ae1037207aaac74fcd75e809cf993f88b52e463979b68bd123fe925e491a7030a WHIRLPOOL 66782323a455af7536592cf76c9fd9f57c8adf8a67b374c4e6bb96fdc21dfb8add4f74697139643c47561357a451d50b777f3e2e73db850176fc05d61ae6e54c
+EBUILD eselect-python-20160516.ebuild 1101 SHA256 5b2652f2aef7807e9548866c90ad54821dd93b32859253bb183cfbabbc1e0c3d SHA512 a8ebae6634638f735adeb741f182aa10484225a6d5458f7bd08fa0b043d8160c9f164d64854d682e1b867c1be8c9a5a42c475efec9a784bce80fd9ac08054924 WHIRLPOOL 5fe40f5513ce5eada625d3791a581d8525b3c56ac6ad584251c2d09e406261b7458860e6bc6f7bc33dc5a0b6cd02f6aacd29f0ab9b029ed0bb6527a88fe9829d
+EBUILD eselect-python-99999999.ebuild 1102 SHA256 160f5a8b92e8b7b5576e4a2437f5f988a7ba992b71c0e851749819e2da0c517b SHA512 f7bf212d900b56e8a31fa83cfdb050a1f345f8ec9d9e864abc69857930f272637612a5f1a1c0eb7b2285237e6810002a830698ac5326be2d7446bf6ab0b180e1 WHIRLPOOL fecd1127b8fb61132b88ed74021332bab0c504da6ae978d189ff66ee3b01679b79a8746815a0ffe2bd6bc52571f3de068c09a7f46056ad97d6f8e8f4a176111c
+MISC ChangeLog 8479 SHA256 f2ff7d201bc9d2f19df63c80d09bd4c8525d591081ede29d430952cc3ac00b89 SHA512 b77db3847195fca3df3b73340e5118a8e62edfd2fa415d0ff895c8c4a77f967d50f33cc7d56cf2ac47d44e5d311795715477d49caf96b7a4812596e3fb2b1ea0 WHIRLPOOL 7dba1022926db356e2b52e0f7f86f89c8324f381337552ff0b6399b5b1728365a1ee5658a0a1e7e8cf3a705e229c4e76ecc2cf43b40d69a8bc38768240c10717
+MISC ChangeLog-2015 13659 SHA256 9224650f5d5f3a3a39ae9ff3f11dbd87a27a63c1bef8dd449b7edfa7a70e3bee SHA512 100fd16b8d27afe9e2b6600ad8d3ff9d002a6bac7dd35c0fe95e1112bdb4bfaa374d74a5fbde2fe31fd45c78932ec7d7ba1a0d7e08121d9197ecf0ec47a9440f WHIRLPOOL 9cb53914a03ad2676f9e6fab277ac188f49ee5be6c8be388cd13b93d592821d4bd08c18c03af44d6a0bf36149f208cdd4d4813233a46736ee205ba89042e92eb
+MISC metadata.xml 240 SHA256 07a76e79a43ffd9aa15de0e4ae548ea85aa5bd165c4602630c3519e60f113ee6 SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59 WHIRLPOOL e3e059953c7c36bd942545f4e2a0e94ba938a17fe2bd04df81b137c185e64a213152c11918922563509e4767e601b41105f80c5983a87ee4d6be7704bcf7cf54
diff --git a/app-eselect/eselect-python/eselect-python-20160516.ebuild b/app-eselect/eselect-python/eselect-python-20160516.ebuild
new file mode 100644
index 000000000000..86d4d850fdd4
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20160516.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# python-exec-2.4.2 for working -l option
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2"
+
+src_prepare() {
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/eselect-python-99999999.ebuild b/app-eselect/eselect-python/eselect-python-99999999.ebuild
new file mode 100644
index 000000000000..3b35998a3dc1
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-99999999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# python-exec-2.4.2 for working -l option
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2"
+
+src_prepare() {
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/metadata.xml b/app-eselect/eselect-python/metadata.xml
new file mode 100644
index 000000000000..7f4f33c6dbc9
--- /dev/null
+++ b/app-eselect/eselect-python/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>