summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-postgresql/eselect-postgresql-2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-eselect/eselect-postgresql/eselect-postgresql-2.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-eselect/eselect-postgresql/eselect-postgresql-2.3.ebuild')
-rw-r--r--app-eselect/eselect-postgresql/eselect-postgresql-2.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-eselect/eselect-postgresql/eselect-postgresql-2.3.ebuild b/app-eselect/eselect-postgresql/eselect-postgresql-2.3.ebuild
new file mode 100644
index 000000000000..18d367b4ed37
--- /dev/null
+++ b/app-eselect/eselect-postgresql/eselect-postgresql-2.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Utility to select the default PostgreSQL slot"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://dev.gentoo.org/~titanofold/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RDEPEND="app-admin/eselect"
+
+# All dev-db/postgresql ebuilds from 10.0 on are well supported. Earlier
+# ebuilds may present some quality of life issues.
+PDEPEND="
+ !<dev-db/postgresql-9.6.2-r1:9.6
+ !<dev-db/postgresql-9.5.6-r1:9.5
+ !<dev-db/postgresql-9.4.11-r1:9.4
+ !<dev-db/postgresql-9.3.16-r1:9.3
+ !<dev-db/postgresql-9.2.20-r1
+"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins postgresql.eselect
+
+ dosym eselect /usr/bin/postgresql-config
+}
+
+pkg_postinst() {
+ postgresql-config update
+}