summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild')
-rw-r--r--app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild b/app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild
index 1206be17c265..4254b036e4ec 100644
--- a/app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild
+++ b/app-eselect/eselect-opengl/eselect-opengl-1.3.1-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,7 +20,7 @@ SRC_URI="https://dev.gentoo.org/~mgorny/dist/opengl.eselect-${PV}.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE=""
DEPEND="app-arch/xz-utils"
@@ -49,11 +49,15 @@ pkg_preinst() {
}
pkg_postinst() {
- if path_exists "${EROOT}"/usr/lib*/opengl; then
+ local shopt_save=$(shopt -p nullglob)
+ shopt -s nullglob
+ local opengl_dirs=( "${EROOT}"/usr/lib*/opengl )
+ ${shopt_save}
+ if [[ -n ${opengl_dirs[@]} ]]; then
# delete broken symlinks
- find "${EROOT}"/usr/lib*/opengl -xtype l -delete
+ find "${opengl_dirs[@]}" -xtype l -delete
# delete empty leftover directories (they confuse eselect)
- find "${EROOT}"/usr/lib*/opengl -depth -type d -empty -exec rmdir -v {} +
+ find "${opengl_dirs[@]}" -depth -type d -empty -exec rmdir -v {} +
fi
if [[ -n "${OLD_IMPL}" && "${OLD_IMPL}" != '(none)' ]] ; then