summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-electron/eselect-electron-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-31 15:47:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-31 15:47:53 +0000
commitd950fa39dbe16d164ed0cb8e3036fd5d0d896a4c (patch)
tree04f92d5d1070a7aedb970ce4539dc6d60253c4df /app-eselect/eselect-electron/eselect-electron-2.1.ebuild
parentbd7908c6630f38067350d396ac5d18c3cc2434a0 (diff)
gentoo resync : 31.10.2017
Diffstat (limited to 'app-eselect/eselect-electron/eselect-electron-2.1.ebuild')
-rw-r--r--app-eselect/eselect-electron/eselect-electron-2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-eselect/eselect-electron/eselect-electron-2.1.ebuild b/app-eselect/eselect-electron/eselect-electron-2.1.ebuild
new file mode 100644
index 000000000000..5a7856b25c22
--- /dev/null
+++ b/app-eselect/eselect-electron/eselect-electron-2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Utility to select the default Electron slot"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://github.com/elprans/${PN}/archive/v${PV}.tar.gz -> eselect-electron-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins electron.eselect
+ dosym eselect /usr/bin/electron-config
+}
+
+pkg_postinst() {
+ electron-config update
+}