summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
commit8fd9d385e5bc3c01115ec2ddcb2227607eb90861 (patch)
treeaba1e6ef6b95e94172c009394cd1fcbc383e7d6e /app-emulation
parent1ddcee0bd115d2f843f82061cb0d1741bf90151d (diff)
gentoo auto-resync : 05:01:2024 - 14:04:25
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/86Box/86Box-3.11.ebuild77
-rw-r--r--app-emulation/86Box/86Box-4.0.1-r1.ebuild4
-rw-r--r--app-emulation/86Box/86Box-4.0.ebuild77
-rw-r--r--app-emulation/86Box/Manifest7
-rw-r--r--app-emulation/86Box/files/86Box-4.0.1-incompatible-pointer-types.patch23
-rw-r--r--app-emulation/Manifest.gzbin15142 -> 15152 bytes
-rw-r--r--app-emulation/ski/Manifest2
-rw-r--r--app-emulation/ski/ski-1.4.0.ebuild45
-rw-r--r--app-emulation/vice/Manifest2
-rw-r--r--app-emulation/vice/vice-3.8-r1.ebuild (renamed from app-emulation/vice/vice-3.8.ebuild)4
10 files changed, 78 insertions, 163 deletions
diff --git a/app-emulation/86Box/86Box-3.11.ebuild b/app-emulation/86Box/86Box-3.11.ebuild
deleted file mode 100644
index 1eb0faf7f95e..000000000000
--- a/app-emulation/86Box/86Box-3.11.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Emulator of x86-based machines based on PCem"
-HOMEPAGE="https://github.com/86Box/86Box"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="dinput experimental +fluidsynth +munt new-dynarec +openal +qt5 +threads"
-
-DEPEND="
- app-emulation/faudio
- dev-libs/libevdev
- media-libs/freetype:2=
- media-libs/libpng:=
- media-libs/libsdl2
- media-libs/openal
- media-libs/rtmidi
- net-libs/libslirp
- sys-libs/zlib
- qt5? ( x11-libs/libXi )
-"
-
-RDEPEND="
- ${DEPEND}
- fluidsynth? ( media-sound/fluidsynth )
- munt? ( media-libs/munt-mt32emu )
- openal? ( media-libs/openal )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qttranslations:5
- dev-qt/qtwidgets:5
- kde-frameworks/extra-cmake-modules
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- # LTO needs to be filtered
- # See https://bugs.gentoo.org/854507
- filter-lto
- append-flags -fno-strict-aliasing
-
- local mycmakeargs=(
- -DCPPTHREADS="$(usex threads)"
- -DDEV_BRANCH="$(usex experimental)"
- -DDINPUT="$(usex dinput)"
- -DDYNAREC="ON"
- -DSLIRP_EXTERNAL="ON"
- -DMUNT_EXTERNAL="$(usex munt)"
- -DFLUIDSYNTH="$(usex fluidsynth)"
- -DMINITRACE="OFF"
- -DMUNT="$(usex munt)"
- -DNEW_DYNAREC="$(usex new-dynarec)"
- -DOPENAL="$(usex openal)"
- -DPREFER_STATIC="OFF"
- -DQT="$(usex qt5)"
- -DRELEASE="ON"
- )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- elog "In order to use 86Box, you will need some roms for various emulated systems."
- elog "See https://github.com/86Box/roms for more information."
-}
diff --git a/app-emulation/86Box/86Box-4.0.1-r1.ebuild b/app-emulation/86Box/86Box-4.0.1-r1.ebuild
index cc978ae05ad0..16aac070243a 100644
--- a/app-emulation/86Box/86Box-4.0.1-r1.ebuild
+++ b/app-emulation/86Box/86Box-4.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -51,6 +51,8 @@ RDEPEND="
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${PN}-4.0.1-incompatible-pointer-types.patch" )
+
src_configure() {
# LTO needs to be filtered
# See https://bugs.gentoo.org/854507
diff --git a/app-emulation/86Box/86Box-4.0.ebuild b/app-emulation/86Box/86Box-4.0.ebuild
deleted file mode 100644
index e7aba1c39380..000000000000
--- a/app-emulation/86Box/86Box-4.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Emulator of x86-based machines based on PCem"
-HOMEPAGE="https://github.com/86Box/86Box"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="dinput experimental +fluidsynth +munt new-dynarec +openal +qt5 +threads"
-
-DEPEND="
- app-emulation/faudio
- dev-libs/libevdev
- media-libs/freetype:2=
- media-libs/libpng:=
- media-libs/libsdl2
- media-libs/openal
- media-libs/rtmidi
- net-libs/libslirp
- sys-libs/zlib
- qt5? ( x11-libs/libXi )
-"
-
-RDEPEND="
- ${DEPEND}
- fluidsynth? ( media-sound/fluidsynth )
- munt? ( media-libs/munt-mt32emu )
- openal? ( media-libs/openal )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qttranslations:5
- dev-qt/qtwidgets:5
- kde-frameworks/extra-cmake-modules
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- # LTO needs to be filtered
- # See https://bugs.gentoo.org/854507
- filter-lto
- append-flags -fno-strict-aliasing
-
- local mycmakeargs=(
- -DCPPTHREADS="$(usex threads)"
- -DDEV_BRANCH="$(usex experimental)"
- -DDINPUT="$(usex dinput)"
- -DDYNAREC="ON"
- -DMUNT_EXTERNAL="$(usex munt)"
- -DFLUIDSYNTH="$(usex fluidsynth)"
- -DMINITRACE="OFF"
- -DMUNT="$(usex munt)"
- -DNEW_DYNAREC="$(usex new-dynarec)"
- -DOPENAL="$(usex openal)"
- -DPREFER_STATIC="OFF"
- -DRTMIDI="ON"
- -DQT="$(usex qt5)"
- -DRELEASE="ON"
- )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- elog "In order to use 86Box, you will need some roms for various emulated systems."
- elog "See https://github.com/86Box/roms for more information."
-}
diff --git a/app-emulation/86Box/Manifest b/app-emulation/86Box/Manifest
index 7eb8bb6c4c4e..e5ce8caf4d09 100644
--- a/app-emulation/86Box/Manifest
+++ b/app-emulation/86Box/Manifest
@@ -1,7 +1,4 @@
-DIST 86Box-3.11.tar.gz 4593971 BLAKE2B 0b2771492910f0c11835104e5ef7495ca052414a959e27732ec0d72bc6a6f4cb46c386f0642042425cfd4c4aa1b16e24e027e53034ffae618d9c51aff282cdf7 SHA512 4705f0bb7186a19b8a74450132a73c01e9fae80809e7cebf2ef0294100081ff6a27e0f81dbc661596a8d1cd7b04afc5dddb3e990dd10951a37a48de338c49a77
+AUX 86Box-4.0.1-incompatible-pointer-types.patch 826 BLAKE2B 79080877c25dc1292e743a03225ec95994284d7999443da91e81f492dc2c7e8d7e2987304fbb21b62c3cb6406a175c90f821963822db609436cf10fee36077e3 SHA512 270960bfad2b99b0c4c8d7e3b889f0601490ed780c5ddde619efdb57bdf6d20309e079b77a986625a7824bbc5dce47199a1534be0bef0b9448221ff52cab5457
DIST 86Box-4.0.1.tar.gz 5206128 BLAKE2B 56a4d374757eb67368bbc5782bceca3f4dec79dd36fad6698065a86c3937238b352425dd856169a1a65a42a4f60f1a68b099ece4a7c019be4229d61fabfc444a SHA512 b06a8c50558276f35f98795e0513b5bd39eed3a0d3a8d61bf79b373501cd823ab3ab12fb943e879a240292bca39c507a1a42b1b6f3f9ae596499b685a03acf98
-DIST 86Box-4.0.tar.gz 5200746 BLAKE2B 74f702d7be42ee84a4ca337e13bb77ec3fb89b1e78018807d8ced63e474905799f1cf6bf7c093f17dedcc6da0c07b0283f9e2c490f3b3f7ba3c4f1689988b8d4 SHA512 8465e86e44bb5fa260f0550479e877a0f4a407eb59a00db8bab6764fecb292b8c9a370451eb71adbf84db990d7ea70e001cd1b2bc096c95caa7526901d20833e
-EBUILD 86Box-3.11.ebuild 1730 BLAKE2B 109ffe90a69d81fdf5f71091c2cba14e4f1793ef0140670bd78ab227f761a9497828504b1752a494a11f04d25af223f961486110e0d9be6695874197e724205f SHA512 fe7fa911a8f04c2def855fe830d2f89dffc41bb72c8a8e1e742ce4fe01c44b92d64c2e0a14c0dcc940cabd625828f1b29f33d8098ba3ad3caea86e2f2d5e1683
-EBUILD 86Box-4.0.1-r1.ebuild 1914 BLAKE2B 6e2c76bf8bdf21f288e00f549747aba658f787ffc7470b072a2af5c187936d8901234bd07ea937b155ac2ea34dfcedcf45473205ce8547e8e0fb55a32b1ea01b SHA512 c48a360e0bc5b2860db1ad544b8eaeeabc5369617ae44b16c7e4087f25c9215979a56615142fa7eeb4d38960d6cc10368cea561bdb8cb02a96d6b66610b2d81b
-EBUILD 86Box-4.0.ebuild 1722 BLAKE2B ac17d931d437b02a0f4dfd7d56ced50c6fc81d33f0ad099964204fb4c3f62557ee735bc7182d2f89f06a6388eb7f7f0aca8adb06ec2a444c39be31d3b61b5763 SHA512 46c30bfdd94995c3590729e86b28be1b58465d5080c2c592efed0d9aadb124de760a6ee9f5e3cdd14b80d4c366115f41c2b304f7a879c64827619c1bd9bf1e1b
+EBUILD 86Box-4.0.1-r1.ebuild 1986 BLAKE2B eec97b40da1265d7727cc8bc0112d5d6d307b498d4bc75f071b861183df9b4afdd5adb2ede1adf32ff207f7e4918b5da4bed42218c81a2b59aa0053194da649b SHA512 a36bbfc49c6fe1e40a3ac495304669a5d5fa0e4694da09cfefa6d3cb33d134a963d299f84685a22eba9a87f468e1cee443b67f2b1f2fdefb6242de95646442c7
MISC metadata.xml 1162 BLAKE2B 3293da00bec68462e7488dca4d16aa1a6f1e49be1bfd49b8ee5546e247440b7390f78089cc74293b62d18dec7ee0db4a80ed2de2d12401a1b5ebec80275f5646 SHA512 e0d1f641a1b3e751655b1665d4df758cfc648de47770552ce78d136946c322da4a0140358575fd3ed9adbb87d83aa4b28a6c8eda0be375fde0cd77b0b5718c9b
diff --git a/app-emulation/86Box/files/86Box-4.0.1-incompatible-pointer-types.patch b/app-emulation/86Box/files/86Box-4.0.1-incompatible-pointer-types.patch
new file mode 100644
index 000000000000..df708d337b65
--- /dev/null
+++ b/app-emulation/86Box/files/86Box-4.0.1-incompatible-pointer-types.patch
@@ -0,0 +1,23 @@
+From 13d582b56faf9caca114ec5625b34a7859ecb41f Mon Sep 17 00:00:00 2001
+From: OBattler <oubattler@gmail.com>
+Date: Fri, 5 Jan 2024 13:01:17 +0100
+Subject: [PATCH] Unix: Use proper parentheses to cast the result, not the
+ flags, fixes #3994.
+
+---
+ src/unix/unix.c | 4 +---
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/unix/unix.c b/src/unix/unix.c
+index e784df38e6..cfa8243135 100644
+--- a/src/unix/unix.c
++++ b/src/unix/unix.c
+@@ -635,7 +635,7 @@
+ SDL_MessageBoxData msgdata;
+ SDL_MessageBoxButtonData msgbtn;
+ if (!header)
+- header = (void *) (flags & MBX_ANSI) ? "86Box" : L"86Box";
++ header = (void *) ((flags & MBX_ANSI) ? "86Box" : L"86Box");
+ if (header <= (void *) 7168)
+ header = (void *) plat_get_string((int) header);
+ if (message <= (void *) 7168)
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index dad4ff996a25..d97629069f3a 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/ski/Manifest b/app-emulation/ski/Manifest
index ed461cef1d42..fb3b63694945 100644
--- a/app-emulation/ski/Manifest
+++ b/app-emulation/ski/Manifest
@@ -12,5 +12,7 @@ AUX ski-1.3.2-remove-hayes.patch 682 BLAKE2B 5a304115ac6353b1c61ae4ddeeebc821ced
AUX ski-1.3.2-syscall-linux-includes.patch 397 BLAKE2B dfb72fef3be8110ab5acacb8fa0f33e8c68fc5de873b92398dd4a048307f3d4db47eb2d04a8323ce3748e893e190d42ca5168de442c892edff92834544edad52 SHA512 f0784af8eb8ecc8df92f96f1ce2f714f4cb1a9e60409a06c02cf300316a9680b01be6b6d1f83854b1fb3bd364cf0b08262a99a63190695fd9722691ef1fa3d6f
AUX ski-1.3.2-uselib.patch 582 BLAKE2B b0d91fed1a01c6d4c2db464a1dbe6c4855a0302eacb21367865a3510b081a95756f1b09f79a015a1e20b3cb87d31e08785a5abed4a661203aec82a4a311538bf SHA512 f119e1a18ef08f40758fa1ddde61a88533b432c75111bba38ffc134edfee66f28ee01336509ed106461bddfc438d1eac48213ab4940e82f5128b924e584b974e
DIST ski-1.3.2.tar.gz 2715791 BLAKE2B 5e6b237ea21bf410e44dbaa88150d980f2af66728effeab4e8bcef02f27c24069c4bcaf42d3814ad15c3bd759819d468f163b6c64a89408c09d1ffbdc9302c0f SHA512 21f2e1dd87cb517602d4d6ef62707ec6042c1b6ec5dfd063db7315d13bbc3fb47b491c15b7efb0433fc82f27c7924e2d50b2f57fe24e49aeb864ce2c3c2c8bd0
+DIST ski-1.4.0.tar.xz 2373876 BLAKE2B c9c20582274dd6db6e216c709a1793b55ac2c1aaf26c5e235bffdd190e9e7dca4c7ef37f96309c61ba9b5f03229966710a65405e2a345d65a08b9163f545c85b SHA512 855bc73c2cd93d890cd532db524eecc122d5f3eddf189efdbf34069d1c9bd7b7f98d5e593387fdc31b38fc8630f00b6b126f5c1a1f22dab57447e024b9015cf5
EBUILD ski-1.3.2-r4.ebuild 1506 BLAKE2B 90836a677e69fb8ebf30da8e387f48b440999de416f2924e4e11d0db2a3b36f55b1050a67bf04b3ab86319664cfe8b0493328907debf72c45254ed990d959b53 SHA512 e9c9f64fb7230421a12a910ee4d46e9defe4ee6a9ef85fa8fe47bc9f7a6afa91bc2eb387736639682848b1e01be433f079a08c822c687a30ccd5a5fa66468892
+EBUILD ski-1.4.0.ebuild 854 BLAKE2B ea556308386607363fe65ff161228dc43c2c69393d85bb699f522fd44710b38a18b741c67668be0c888b51e686efef55d07d5245f3971a20d1c2a31d0e3081d2 SHA512 c269a9ca3a53588eb40a43075d166d06abbecc7fa8b8d67b8c76dd02d14e0b6c3726c6805a13e38ce48a6b0690f34667930a2e0b462449c70cbeeb5622ee84f1
MISC metadata.xml 411 BLAKE2B d9b6023db6462b087fa1acb3767fd0b29ab4f02014a7a3aff864ee518d689bbb95980fdd6d7d561c424b1cda2dac45fc12e8c885af877877206deda14f7f4b2f SHA512 3dbce520f1b8ce4beea04f912341167e8283cf6e6be3a9db796d393219cafff6408f93b1af60f39b3e521f96dd1c5f7a4b214002aad29bf64249a4fa30dfc00f
diff --git a/app-emulation/ski/ski-1.4.0.ebuild b/app-emulation/ski/ski-1.4.0.ebuild
new file mode 100644
index 000000000000..1867d53df65f
--- /dev/null
+++ b/app-emulation/ski/ski-1.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="ia64 instruction set simulator"
+HOMEPAGE="https://github.com/trofi/ski http://ski.sourceforge.net/"
+SRC_URI="https://github.com/trofi/ski/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug motif"
+
+RDEPEND="
+ dev-libs/libltdl:=
+ sys-libs/ncurses:=
+ virtual/libelf
+ debug? ( sys-libs/binutils-libs:= )
+ motif? ( x11-libs/motif:= )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/gperf
+"
+# games-sports/ski and app-emulation/ski both install 'ski' binary, bug #653110
+RDEPEND="
+ ${RDEPEND}
+ !games-sports/ski
+"
+
+src_configure() {
+ # bug #854531
+ filter-lto
+
+ local myeconfargs=(
+ --without-gtk
+ $(use_with motif x11)
+ $(use_with debug bfd)
+ )
+
+ econf "${myeconfargs[@]}"
+}
diff --git a/app-emulation/vice/Manifest b/app-emulation/vice/Manifest
index 307737840330..f8283526de85 100644
--- a/app-emulation/vice/Manifest
+++ b/app-emulation/vice/Manifest
@@ -1,5 +1,5 @@
DIST vice-3.7.1.tar.gz 13444946 BLAKE2B 64ac82c118cd1e515d7677d3f60d3b19dbf19319d8505321c46c2adb92414193784a036e2f6fa0ce5f55f1e4f425f45026ce152ee866b72ad6557531faaf5797 SHA512 80f81dd4d163cc5030eee2908b274bce4f3f21a3adb6d01559f4695d58b27ebc7b7570d8896718dfe74b2f2e4983ed3f9c4919b6e81934063d344b543b081f30
DIST vice-3.8.tar.gz 13564021 BLAKE2B 709fd6eda874de542e5770a328b0c0308d04f755e3bf1fceba5147156eb894a95ce6f14e9f8848ca6992d4f958082f83a198d2176c1fe54e87027c7dfac8849c SHA512 fe644667736c32386b62af53314a95bf510c75d476eaab14b4c37693f2f57d6815126ab3db2f0cb11300c1a4a07c29b3f25210800ce97a673a0460ab59d0ebba
EBUILD vice-3.7.1.ebuild 4476 BLAKE2B f9bc62af5c9a7326d0f6827e9a6ca15f436b022161283633cb618067aa061a37c608c7843ac95bb86cff2d57b6c90fd1c510b21464b0b23b0f5fc5480ec8a236 SHA512 ad97ef3353949c3eb736c00c0c70a7236843ce9cbeeb521341f8d662311343e9ddcc59e0cb9e1cfa6f572af0bcb0b8a0c5cbe496f7c412b0405c6caa64e1a06c
-EBUILD vice-3.8.ebuild 4345 BLAKE2B a698815ecb07e4a52b81f31343a097c8d3b318402dae97cd51e19db2102206b721903ad4e1d887b4bfbd2c38fe90b0e88a0f50970ff8a380beabaed83933beb2 SHA512 acda516cca554d7a8f1af26bcdc5fe879da90b3a6e77fe4c4ead3bc572ee52de08a128854598398e996652a2f834651a196bad1c3c38240ec3178ccdd1e55709
+EBUILD vice-3.8-r1.ebuild 4306 BLAKE2B 0d6bad08924137fae205c43df29f76b8f271682350b9a192f83dbff41621aa865ba9c41b351a1885dfef28646f2b270dd8d62b66f914830797ed921ce44364d1 SHA512 6f2c3fbd62b07415a5ef6def9338b3b524ccf59c904337c2adf4891b891394db8423126c0439177e4da9f5aec77cc15554a0035a3c07d0ac7736ed35adeae6bb
MISC metadata.xml 693 BLAKE2B 5b5c1b4ad182846cacfca3b347fe8601a993c1b78dc73b7e221353eba6591748075e92015d9dcc105e991b4268c453fed3aa699059bfe9e626e95c553cc3a78d SHA512 817ecc54419d93fb2bdcaac1c41a363937c495d8092a34ff4edb3f4db22522b5ec9757710d2f1447b4edd69343a226b1454e6cddd785a21b29151da0ef73b8bc
diff --git a/app-emulation/vice/vice-3.8.ebuild b/app-emulation/vice/vice-3.8-r1.ebuild
index 9d9694f87608..def4ab4e7450 100644
--- a/app-emulation/vice/vice-3.8.ebuild
+++ b/app-emulation/vice/vice-3.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -42,7 +42,7 @@ RDEPEND="
x11-libs/pango
)
lame? ( media-sound/lame )
- mpg123? ( || ( media-libs/libmpg123 <media-sound/mpg123-1.32.3-r1 ) )
+ mpg123? ( media-sound/mpg123 )
ogg? (
media-libs/libogg
media-libs/libvorbis