summaryrefslogtreecommitdiff
path: root/app-emulation/xcpc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-emulation/xcpc
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-emulation/xcpc')
-rw-r--r--app-emulation/xcpc/Manifest6
-rw-r--r--app-emulation/xcpc/xcpc-0.35.0-r1.ebuild29
-rw-r--r--app-emulation/xcpc/xcpc-0.36.0.ebuild29
-rw-r--r--app-emulation/xcpc/xcpc-20070122.ebuild15
4 files changed, 62 insertions, 17 deletions
diff --git a/app-emulation/xcpc/Manifest b/app-emulation/xcpc/Manifest
index 20284132b043..f14db6b93ad8 100644
--- a/app-emulation/xcpc/Manifest
+++ b/app-emulation/xcpc/Manifest
@@ -1,3 +1,5 @@
-DIST xcpc-20070122.tar.gz 496627 BLAKE2B 13fc9974e3810fa4ef45e90764641cb0a220657055829d1ec9a185c1a894234d3a654581e317327ac5937454b9dfab14af2654775157041edcc0176975753835 SHA512 7f5700340fbbf23d2f2111e31ce803c846799ef6681cf63e28bc67564e092534fc4140cb99d718fae9126668ee8f3053bbd097537c04637b5b809ce7b986dd26
-EBUILD xcpc-20070122.ebuild 413 BLAKE2B 8dc9025016c763adc46a5c43e5f50d169c363550e53ee4ae7eb0a2254bfdb46ea1774897f0387802aa74be674e966555540eb38e710de18bd115931740dcc6a3 SHA512 a7739158b5ad9e6f7fb37446fef1d270c07291330ac395c59b0feb6d50c750cf1c15e0dbc4e75ce62b9bb4ce0732061d94a5c3ac6f39db629691d75b3bc8e54d
+DIST xcpc-0.35.0.tar.gz 1058202 BLAKE2B f5002fcc69a078cd05c05a981522edd15900295136419157f997effd81a89f7452cec335bbdba0be3b303bdc8f8537d4aac255ee7cf4e9ec53cc1143413ad1c1 SHA512 667db6db33f2cab85647960edb5b1c200037bfc464527a60eca85c31549360226893853a38d98e657bde111a28aca47d9741b16b13284759b66cb6213da27458
+DIST xcpc-0.36.0.tar.gz 1092363 BLAKE2B 4f799aefa417f6e2c04c0c3760c4d15b10b863f528e5051cfe90ea5a8ccb4c3f83fb592bbf510a351c02dc42a2a2a42f9fcb33b65a5e2dd997feeb5ea22f5342 SHA512 0cf6e718daf6b7db981aa607036e57eddb2ae18665393b0a691d8fd6978278ca077ae45a205eae93b6107b83d5d219702018f1afcda84ae7b83a7b6d68a68cba
+EBUILD xcpc-0.35.0-r1.ebuild 571 BLAKE2B 475b1a073db3c2662f11f065fee8c45a8fa1a94cf482b3ec5fb40e0b90f5ccaa68c395119fc0b61e57cafeaa02dd9147abfe24249b095d4b47a05a3f7829a0e2 SHA512 37097b2d544a373f6824e09b082f65d50fc06b898b91da205df11741f1d9b8ff05940010b8451ba06c919d59c01eb6be7a5480c6bf65b10817e60b149a32292f
+EBUILD xcpc-0.36.0.ebuild 586 BLAKE2B 3253621b8950be262fb991c899184eb586874f96e6c4a2189ba4740fad658ad961eca75e01e750ab76c00b67a7c07e00a4065b09dc7c701309c111e2ce1992e3 SHA512 1d108f7a5bb7ef7e2bd2b626b0209f3f61b00366d27ddd24fe056e4dfbdaf482a4f316a59342da680b7c24328b4acfd45bb5a9f352992c95f54cc40e02a970dc
MISC metadata.xml 241 BLAKE2B 81cba32d3549528c5580b252ea1d827f5b8a72f02da156bef7c434d60d9356140f4f86ca455d6230970659413ef6d40e6ec3648f66ce110816a611ecd608677c SHA512 917345e02375f9f0638188543e2479a7b88616d7e4c732570eb0b5a903fa74d62386a8729000737e9697ef14c0ca73a82d2d0ec4fe39bfa98aa0d7ef796950b9
diff --git a/app-emulation/xcpc/xcpc-0.35.0-r1.ebuild b/app-emulation/xcpc/xcpc-0.35.0-r1.ebuild
new file mode 100644
index 000000000000..c70f06d7fd56
--- /dev/null
+++ b/app-emulation/xcpc/xcpc-0.35.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="XCPC is a portable Amstrad CPC 464/664/6128 emulator written in C."
+HOMEPAGE="http://www.xcpc-emulator.net/doku.php/index"
+SRC_URI="https://bitbucket.org/ponceto/xcpc/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/motif"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --disable-athena \
+ --enable-motif2
+}
diff --git a/app-emulation/xcpc/xcpc-0.36.0.ebuild b/app-emulation/xcpc/xcpc-0.36.0.ebuild
new file mode 100644
index 000000000000..add31369b9f2
--- /dev/null
+++ b/app-emulation/xcpc/xcpc-0.36.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="XCPC is a portable Amstrad CPC 464/664/6128 emulator written in C."
+HOMEPAGE="http://www.xcpc-emulator.net/doku.php/index"
+SRC_URI="https://bitbucket.org/ponceto/xcpc/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --disable-athena \
+ --disable-motif2 \
+ --with-x11-toolkit=gtk3
+}
diff --git a/app-emulation/xcpc/xcpc-20070122.ebuild b/app-emulation/xcpc/xcpc-20070122.ebuild
deleted file mode 100644
index bfe344f89853..000000000000
--- a/app-emulation/xcpc/xcpc-20070122.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="XCPC is a portable Amstrad CPC 464/664/6128 emulator written in C."
-HOMEPAGE="http://www.xcpc-emulator.net/doku.php/index"
-SRC_URI="http://sourceforge.net/projects/${PN}/files/${PN}/${P}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="app-emulation/libdsk"